cancel
Showing results for 
Search instead for 
Did you mean: 

HANA Cloud XSOData Fails on Update

AlexandreFossat
Explorer
700

I built a xsodata service in BTP Cloud Foundry using the node package (@sap/xsjs) for retrocompatibility and my xsodata GET, POST and DELETE is working fine, but the PUT method is giving me the following error:

Checking the LOG section of my application (xsodata node service) in BTP, I noticed this error:

"msg":"[24][0] SQL Exec::Error: \nError: feature not supported: UPDATE FROM statement isn't supported"

Searching a bit about this error, I noticed tat the "UPDATE FROM" features doesn't work in HANA Cloud anymore. Is it possible that the node package from SAP (@sap/xsjs) is implemented with this error for the PUT method, or am I missing something?

In case of any doubt, here's my code: https://github.com/AlexandreFossati/mta-xsodata

AlexandreFossat
Explorer
0 Kudos

Any advices?

michal_majer
Active Participant
0 Kudos

Hey Alexandre,

Could You show how You are sending PUT request?

Best,
MM

AlexandreFossat
Explorer
0 Kudos

Hello Michat Majer,

Here's the GET request proving that the record did exist.

Here's the PUT request failing

AlexandreFossat
Explorer
0 Kudos

Any advices?

Accepted Solutions (0)

Answers (1)

Answers (1)

SergioG_TX
Active Contributor
0 Kudos

I had a similar issue... what I had to do was a merge statement in HANA cloud rather than an update statement which is not allowed - in my case i was using a stored procedure being called from a node api. here is the documentation https://help.sap.com/docs/HANA_SERVICE_CF/7c78579ce9b14a669c1f3295b0d8ca16/3226201f95764a57810dd256c...