cancel
Showing results for 
Search instead for 
Did you mean: 

Graph - Correct Lines but Values show $0

Former Member
0 Kudos

I'm using Crystal Reports XI

I have the following graph:

The lines appear to be (relationally) correct for the values, however as you can see all the values are showing $0M.  If I hover over each datapoint, it shows me what would be the correct value for the Yellow line whether I hover over yellow or blue (ie, 2011 Q1 Yellow shows 105880 and 2011 Q1 Blue shows 105880).

For the curious, the values are as follows:

YellowBlue
2011 Q1105880.0034130.05
2011 Q2111282.0045072.67
2011 Q3110495.0049933.12
2011 Q495768.6729735.59
2012 Q1114260.0052252.05

I should point out the values are not direct from the database but are calculated.

I should also point out that the error only occurs on sub-reports.  On my report I have one graph which is directly on the report.  Then there are seven other graphs in subreports which are all then placed on the main report.  The main report graph is correct, all the subreport graphs have the same issues noted above.  The calculations for each subreport are part of that subreport (that is, I'm not passing any values other than linking the parameters)

I tried adjusting the "Data Values" options on the "Axes" tab of the Chart Expert, but no combination I tried has any real effect.

So, what am I doing wrong and, more importantly, how do I fix it?

TIA

Accepted Solutions (1)

Accepted Solutions (1)

former_member260594
Active Contributor
0 Kudos

Hello Clifton,

Can you check in the chart expert > options tba what the numbr format is for the data points?

From your screenshot it looks like it is set to 1M which would explain why it is appearing as 0M as none of you values are great enough to round up to 1M.

Regards,

Graham

Former Member
0 Kudos

In the "Chart Expert", under the "Axes" tab, in the "Data Values" frame, the "Auto Range" box is checked.  The "Number Format" value is "$1M" but it is greyed out (due to "Auto Range" being checked)

If I uncheck "Auto Range" I can change "Number Format" to "$1K" (and then recheck "Auto Range") but there is no difference.

If I leave the "Auto Range" unchecked, the values do appear (sort of) correctly, but the data points don't seem to match the range.

But even still, what happens next quarter when the values go over $1M?

former_member260594
Active Contributor
0 Kudos

Hi Clifton,

In playing with it a bit here it looks like the Data Values Numbr format is changed when you change the number format in the Data(Y) Axis settings. So if you changed it to millions there (right click on one of the Y axis data values and select Data(Y) Axis settings) then go itno the chart expert and ensure that the Data points in the options tab and the Data axis in the Axes tab both set to 1 while Auto Range is still selected does the chart appear correctly then?

Graham

Former Member
0 Kudos

We are real close!!!  Everything is now seemingly showing the correct values.  Thanks for the help (so far).

A couple of small problems/concerns/questions...

1. The currency sign is no longer appearing.  I changed the Y axis settings to "Number" so that I could select "Millions" as abbreviation, and was able to select 2 decimal places, but that removes the currency sign.  If I select "Currency", I cannot select "Millions" as an abbreviation.  While the values should be understood to be dollar values, I'd rather have the dollar sign.

2. Using Millions as the abbreviation does work, but most values are showing up as "0.20M", "0.30M" etc.  I should probably be using Thousands, but what happens when the values do go over a million?  Will it automatically move from "K" to "M"?  Or will I end up with 1,000K?

3. Something else that I can't remember but probably will remember it just about the time I hit "Add Reply". 

Thanks.

former_member260594
Active Contributor
0 Kudos

Hello Clifton,

1) Unfortunately you can only have the currency symbol or the abbreviation, not both. I would recommend going with the abbreviation and in the chart expert > text tab > Data Title uncheck Auto-Text and enter in "In Millions" (or thousands).

2) The abbreviation is not dynamic. I would recommend using 2 charts, 1 with the M abbr. and 1 with k abbr. Then conditionally suppress them based on the group total so that the approriate one is displayed.

Regards,

Graham

Answers (0)