cancel
Showing results for 
Search instead for 
Did you mean: 

GhostScript Windows Server 2008 R2

Former Member
0 Kudos

Hi.

We have successfully implemented the dw_1.SaveAs(path, PDF!) using the "Sybase Powerbuilder PS" printer.

We distribute the gs folder and are adding the printer manually using the ghostpdf.inf file (GS 9.19)

This is working on Windows 7/8/10 and Windows Server 2012 R2 running Microsoft Remote Apps.

However, we are experiencing problems at one customer running Windows Server 2008 R2 (Terminal Server mode and Citrix).

We have tried adding the printer from the ghostpdf.inf file in both version 9.19 and 8.61. No luck.

We have tried to install the GhostScript package first and then adding the printer. No luck.

We have also added the GS_DLL variable and have added the BIN folder to the PATH variable. No luck.

Every time we add the printer, it stops with this error:

"Printer driver was not installed. Operation could not be completed (error 0x00000002)."

Is there anything else we can try?

Is there anything special in Windows Server 2008 R2 that prevents this printer to be installed?

Have anyone managed to install the printer on Windows Server 2008 R2 successfully?

All ideas is greatly appreciated!

Thanks in advance!

Bjarne Anker

Maritech Systems AS

Norway

Accepted Solutions (0)

Answers (4)

Answers (4)

Former Member
0 Kudos

Hi all, and thanks for the answers.

I contacted our customer, and they are not trying to install the printer in Citrix.

The Windows Server 2008 is running XenApp but is set in Terminal Server mode.

He is changing the mode to "install" using "change user /install", but the error is still present.

They will try to add the printer into the printserver and see if that will work instead.

I'm not sure if PB will accept a printer in the network for producing PDF, but time will show.

Regards,

Bjarne

Former Member
0 Kudos

Hello Bjarne,

Not a Citrix expert, but we used to run GhostScript under Citrix at my old employer.  The printer drivers, GhostScript and Printer, had to be defined at the local WorkStation (dumb terminal) level.  The machine local to the user.

Christopher

Former Member
0 Kudos

I've just spoken with my IT support as we are happily running on Server 2008 R2 in terminal services mode. (Not Citrix). Their best guess is that the issue will be around the printer being installed in a Usermode and some conflict within the Citrix trying to install it for All users.

Our conclusion is that the problem is presenting itself because of Citrix and possibly some sort of permissions problem... Best Guess.

Sorry we cannot be more helpful.

Good luck

David

Former Member
0 Kudos

Hi  Bjarne;

FWIW: I have no issues with any Windows version and GhostScript thus far with my government clients. However ... we don't use Citrix. I would suggest passing this issue by a Citrix specialist and see what they say.

In the mean time, this might be of interest (especially Auto Printer Creation vs UPD): A Dummies Guide to Tackle Printing Issues in a Citrix Environment | Brett Loveday | LinkedIn

Regards ... Chris