cancel
Showing results for 
Search instead for 
Did you mean: 

Getting a 'technical error' while running SAP Fiori app on WebIDE

0 Kudos

Hello Everyone,

I created an SAP Fiori application from the templates available in WebIDE. I have created an OData service for SAP HANA data and wanted to display that data in Fiori app.

My internal host status in cloud connector is 'reachable.' Destination connection in SAP cloud platform is successful, the resource is accessible and also I successfully created the SAP Fiori application on WebIDE using templates. But when I am trying to run the app on WebIDE it is giving me the following error.

{

"message": "HTTP request failed",

"headers": [],

"statusCode": 403,

"statusText": "Forbidden",

"responseText": "\n \n \n \n \n \n \n \nThe server refused to fulfill the request.\n\n \n \n More information about why the request was refused may be found in the server logs.\n\n \n <br>Log Out\n \n \n \n \n"

}

I also attached the screen shot for the following error. Can you explain me about this error and how to solve it.

Thank you.

<a href="/storage/attachments/82561-error-run.png">error-run.png</a>

I attached the screenshot of the following error. Please help me to resolve this issue. Thank you.

error-run.png

Accepted Solutions (0)

Answers (5)

Answers (5)

pramod_nagargoje
Explorer
0 Kudos

THere could be two errors

1) Resources are not available through cloud connector destination. Please put path as "/sap" which will enable all resources under parent SAP node

2) ADT is not activated under SICF

Please let me know if you need more details.

Regards,

Ravi Soni

former_member203070
Participant

Hi Ravi,

Thanks for replying.

Although I'm not using any CC here. As all the resources (tables, calculation view, XSOData) are there in my cloud NEO instance trail.

Regards,

Partha

former_member203070
Participant
0 Kudos

is there any solution? I'm having same issue.

Former Member
0 Kudos

I have the same problem and I couldn't find any solution for this issue. Any help??

Joseph_BERTHE
Active Contributor
0 Kudos

Sometimes, the problems comes from the destination name in the neo-app file (from your webide project)

richard-zhao
Employee
Employee
0 Kudos

Hello, SYTYA Could you provide your Http destination configuration details, please?

You could try to change the authentication method to the NoAuthentication of the destination configuration and test again.