cancel
Showing results for 
Search instead for 
Did you mean: 

Getting a MDX Query Error while refreshing a report.

Former Member
0 Kudos

Hi,

I m using SAP BO 4.0 for building our reports.

There is BEX query on top of which Universe is built and report is built based on that Universe.

There were no prompts or filters defined at BEX level. All the prompts/filters/conditions are to be applied at report level.

There were around 16 dimensions and 3 measures in my report.

Two Prompts were created.

1. Against Approved Date and 2. Against State.

5 Filters/conditions were defined at BEX level.

When i refresh the report, i m getting an MDX error. Below is the error message i m getting.

"

Database error: The MDX query SELECT  { (Measures).[35LYTRYAVWK4BUTF5WL7PC9AR] }  ON COLUMNS , NON EMPTY UNORDER( FILTER( CROSSJOIN( CROSSJOIN( CROSSJOIN( CROSSJOIN( CROSSJOIN( CROSSJOIN( CROSSJOIN( CROSSJOIN( CROSSJOIN( CROSSJOIN( CROSSJOIN( CROSSJOIN( CROSSJOIN(  { (ZIPO_ID__ZCALYEAR).[2011] } ,  { (ZICTR_ID).[#] }  ), (ZICTRITEM__0CONTRSTART).[LEVEL01].MEMBERS ), (ZICTRITEM__0CONTREND).[LEVEL01].MEMBERS ),  { (0PLANT__0REGION).[US NY] }  ), (0PLANT).[LEVEL01].MEMBERS ), (ZIPO_ID).[LEVEL01].MEMBERS ), (0PUR_GROUP).[LEVEL01].MEMBERS ), (ZIVENDOR).[LEVEL01].MEMBERS ),  { (ZIPO_ID__ZIPRICING).[TIME & MATERIAL] }  ),  { (ZIPO_ID__ZISEGMNT).[GAS & ELECTRIC], (ZIPO_ID__ZISEGMNT).[ELECTRIC], (ZIPO_ID__ZISEGMNT).[GAS] }  ), EXCEPT(  { (ZIPO_ID__ZICLASS).[LEVEL01].MEMBERS } , {  { (ZIPO_ID__ZICLASS).[STOCK] }  } ) ), (ZIPO_ID__0ENTRY_DATE).[LEVEL01].MEMBERS ), (ZIPO_ID__ZIPOAPDAT).[LEVEL01].MEMBERS ),  (Measures).[35LYTRYAVWK4BUTF5WL7PC9AR] > 100000) )  DIMENSION PROPERTIES MEMBER_UNIQUE_NAME, MEMBER_NAME, MEMBER_CAPTION, (ZICTRITEM__0CONTREND).[2ZICTRITEM__0CONTREND], (ZICTRITEM__0CONTRSTART).[2ZICTRITEM__0CONTRSTART], (ZIPO_ID).[2ZIPO_ID], (ZIPO_ID__ZIPRICING).[1ZIPO_ID__ZIPRICING], (ZIPO_ID__ZIPRICING).[2ZIPO_ID__ZIPRICING], (ZIVENDOR).[20NAME], (ZIVENDOR).[2ZIVENDOR] ON ROWS FROM (ZSC_MPDTD/ZSC_MPDTD_QU0099)  failed to execute with the error Please enter a valid value for characteristic 0PLANT__0REGION.. (IES 10901) (WIS 10901)"

Can some one please suggest how to resolve this?

Thanks,

Prasad.

Accepted Solutions (0)

Answers (1)

Answers (1)

Henry_Banks
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi,

My first point of call would be to : "enter a valid value for characteristic 0PLANT__0REGION"

Consider:  What are you entering ?  Manually or from picklist  ?  and why might it be failing ?

Please Patch up your BI 4.0 to P2.14 if at all possible and retest.

and  keep your BW 7 up to date.  What are you running currently?   (7.01SP10 recommended)

You can get the MDX from the Query Panel (preview SQL button) and can test it directly in transaction MDXTEST in BW to check locally.


Regards,

H

Former Member
0 Kudos

Hi Henry,

Thanks for your response.

Now the issue has been resolved.

Issue is, i tried to create a prompt against a character.

Now i have created a prompt based on the key field for the same and the issue has been resolved.

I have rigorously tested this and it is working fine in all cases.

Thank you once again.

Regards,

Prasad..