cancel
Showing results for 
Search instead for 
Did you mean: 

Gerneric Datasource

m_c5
Explorer
0 Kudos

Hi Experts,

I have a problem with a generic Datasource in BW 3.5!

I want to extract data (txt) from a view in an another sourcesystems to the BW. I have added the corresponding source system with RFC to the BW. Then I have create a generic Datasource in the source system. I run RSA3 and I get the right data.

But how I get this data in my BW? I have an error in reasoning - I try to use the datasource - which I create in the sourcesystem - in rsa3 in the BW but (sure) it doesn`t exists. But If I create the same Datasource in the BW I can`t choose the corresponding VIEW (because this view doesn`t exists in the BW but rahter in the source systems).

What I have forgot alternatively what I have made wrong?

Thanks very much for all answers and hints!

greeez

mrpynk

Accepted Solutions (1)

Accepted Solutions (1)

former_member184494
Active Contributor
0 Kudos

You post is also very generic , in the fact that you could have got the answer by searching the forums as opposed to raising a post about the same

Marian,

You need to replicate the datasource in BW and bring the datasource into SAP BI. And then connect your Objects to the datasource and load the data..

Edited by: Arun Varadarajan on Jan 27, 2009 5:02 PM

Answers (3)

Answers (3)

former_member207028
Contributor
0 Kudos

Hi Marian,

Creation of datasource in Source system is completed, and you also check the data in Source system using T-code RSA3.

not you have to replicate your Generic datasource in BW system, (no need to create it again in BW system). on the source system in BW system right click and select datasource overview and right click on application component under which you have created datasource and right click and replicate, then generic datasource will be replicated on BW system.

now it SAP create infoobjects and infosource map to datasource and load data from source system using infopackage.

hope this helps

Regards

Daya Sagar

Former Member
0 Kudos

in your bw system.

Goto the source system tab in RSA1 select the system you created,right click and say Replicate Datasource.

This will bring the new datasource definition into BW.

Then follow the steps to create Infosource(Comm structure and transfer rules) based upon this datasource.

Create an infopackage under the infosource and then try loading the data into BW.

Also, this infosource should be linked to a target to send data.

hope it helps.

rgs,

Parth.

m_c5
Explorer
0 Kudos

Hi Experts,

thanks for your prompt answers!

I already replicate the datasource how partho has described it. Also I have created an infosource with the right sourcesystem and selected the right datasource - an Infopackage under the infosource I created too. But If I execute this - I get no data in the monitor.

If I go to the RSA3 and want to choose the new datasource: It comes up a system message "DataSource ZPD_00_BUSFUNCTI is not defined in the source system" ?

I really don`t work a long time with BW - so please...be carefull

Thanks for everything!!!

greeez

Mrpynk

former_member181964
Active Contributor
0 Kudos

Hi,

You created the DataSource ZPD_00_BUSFUNCTI in your ECC system?. If you created then it must get in RSA3 and RSO2 (display). If you are not created it in ECC then create it and check it in RSA3.

Thanks

Reddy

Former Member
0 Kudos

Hi

Recheck your entire Data flow at Source system RSO2 ACTIVATE DS -- RSA6-- Transport the DS.

BI data Flow -- RSA13-- Source system -- Replicate DS -- Activate Transfer Rules (Check for the Mappings here) -- Upload the Data into PSA ..

Hope it helps.

Former Member
0 Kudos

You have replicated the metadata for that source system in BW - and build transfer rules etc and then an infopackage?

(sorry - double post!)

Edited by: Simon Turnbull on Jan 27, 2009 11:33 AM