cancel
Showing results for 
Search instead for 
Did you mean: 

Generic Delta for Real-Time DataSource not working NW 2004s

Former Member
0 Kudos
79

Hi,

on the implementation I am working on the generic delta does not appear to be working for Real-Time DataSources. Has anyone seen the same problem or has experience of a solution.

I have created the following:

1. A standard table with a mumeric key representing 'Order Number'.

2. A Generic DataSource using rso2 (a generic delta based on the numeric pointer using the 'Order Number' key, no upper/lower safety interval, real-time enabled, additive delta).

3. A Init InfoPackage for the DataSource

4. A Real-time Delta InfoPackage for the DataSource

5. A Real-time Delta DTP

6. A daemon to load the data scheduled to load every minute.

New records are loaded into the Delta queue succesfully (visible from RSA7).

When I use a standard InfoPackage and DTP to load to my InfoCube the Delta record(s) are loaded and the Delta queue is cleared.

When records are loaded via the Daemon the Delta queue record(s) are loaded but the Delta Queue is not cleared meaning that every time the data is requested the same record(s) is loaded.

I think it is a problem with the Real-time delta request not clearing the delta queue but I can not be sure I have the configuration 100% correct.

Any thoughts???

Ross.

Accepted Solutions (0)

Answers (4)

Answers (4)

Former Member
0 Kudos

This problem disappeared completly after upgrade to SP12. Woo hoo.

Former Member
0 Kudos

Hi

As Mr keppler explained please check the table

Roosource and field REALTIME should have value 'x'..other wise you need to forcely fill this value into this table through a program

Hope it helps

Thanks

Teja

Former Member
0 Kudos

Thanks to all.

The DataSource is real-time enabled and the flag is set in th table ROOSOURCE correctly.

The problem is not that the Real-time data does not load it is that it does not clear the Delta Queue.

I know the data is loaded from the Delta Queue because the table has many records in it. The Delta Queue only one record, I can see this record in RSA7.

The Daemon requests the data from the Delta Queue every minute, however this same record is being loaded over and over. The Delta Queue is not being cleared.

It seems like a bug to me. I have looked through the SDN archive for configuration but have not found an answer to this problem.

Ross.

Former Member
0 Kudos

Hi Robin,

I have worked with real time generic datasources and it was working fine.

But my delta specific field was on Timestamp and not on Numeric pointer.

Are you sure the delta is captured fine with a normal datasource and problem only exists with RDA DS?

Make sure it is capturing the delta properly..

Regards,

Anu.

former_member192700
Active Contributor
0 Kudos

Hi Ross,

Please check whether the DataSource has the field ROSSOURCE-REALTIME set to 'X' in the source system. If not, please search the forum, and you will find multiple thread how to enable a DataSource for Realtime usage.

Cheers

SAP NetWeaver BI Organisation

Former Member
0 Kudos

Hi

what is sp level..it should be sp 10...

Hope it helps

Thanks

Teja

Former Member
0 Kudos

It is sp 10.

The details from teh component Information dialogue is as follows:

SAP_BW 700 0010 SAPKW70010 SAP NetWeaver BI 7.0