cancel
Showing results for 
Search instead for 
Did you mean: 

Generic Data Source(MD-Attr) doesn't extractdata for all the fields

Former Member
0 Kudos

Dears,
                                                                                                                                                                   
                                 
..

We are extracting the master data attribute for 0ORGUNIT via generic extractor, 0COSTCENTER is attribute for 0ORGUNIT.

..

For many orgunit's, costcenter is missing. if I do full repair with the current date as beg and end date under update tab, time dependent data, it will extract the data for all the fields but only less records.

..

Please advise possible corrections for this issue.

..

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hello All,

Data source is based FM and declaration was done twice globally and locally hence there was an issue. Local declaration was commented and extraction worked properly.

Reg,

Guru

Answers (4)

Answers (4)

surendra_p
Active Participant
0 Kudos

Hi Guru,

Please check the data in DS in source system  from which date the data is available and if the DataSource is based on FM then check whether the selections are working fine or not in function module code.

Regards

Surendra

Former Member
0 Kudos

Thanks Geetha, Sai,

I am bale to see the cost center for all the orgunits in RSA3.

I have reduced the data package size and ran but still doesn't work.

Surprisingly there are 30,000 records and it comes as a 5 data packages in BI.

When I check in PSA administration, ONLY FIRST DATA PACKAGE CONTAINS DATA FOR COST CENTER AND COMPANY AREA, FOR REST OF THE DATA PACKAGES NO DATA FOR COST CENTER AND COMPANY AREA. Please let me know if someone has experienced this kind of issue.

Reg,

Guru.

Former Member
0 Kudos

Hi Guru,

Try loading the data in batches by giving the selections in data selection and see if it works.

Thanks,

Rashi

Former Member
0 Kudos

check for the filters in the infopackage.

Former Member
0 Kudos

try to run the request older than 26.09.2008 and check.

Former Member
0 Kudos

You might have already done this but just to understand for resolution. Please ca we know

How did you define the generic extraction in source system. Did you test the data in RSA3 for the same the data source is everything working there.

Try to test the generic extraction in source and see if it pull everything

Thanks & Regards,

Geeta