cancel
Showing results for 
Search instead for 
Did you mean: 

FTP425 error PI FTP adapter

former_member185954
Active Contributor
0 Kudos

Hello Experts,

We have an PI adapter (ftp adapter) configured to send files to a remote ftp server, we have a firewall between PI and remote server. Configuration was done using the following Configuring the Receiver FTP Adapter - Configuring the File/FTP Adapter in Integration Directory/PCK...

Remote server has an IP address that we have configured on firewall with a range of port numbers that we can connect through to on remote server.

The FTP transfers happen in the following manner

1) FTP adapter makes connection to remote host, exchanges userid/password, remote server sends acknowledgement = Works

2) FTP adapter issues PASV command = Works

3) Remote Server responds back with new IP address and port number (the IP address is potentially garbage) = Works

4) PI FTP Adapter attempts to connect on new IP address and port number (IP address is garbage, so it doesn't go anywhere) = Doesn't Work

5) PI FTP Adapter bails out after a timeout.

Has anyone found a solution to this ? is there a way to get PI to use a specific IP address when it issues a PASV command in the FTP adapter.

Is there a way to force PI to continue to use the original IP address that was used to connect to remote host.

I have tried searching on SDN and found the following links:

They don't resolve my problem.

PS: If I login into PI box at unix level and try to use FTP client to directly login into remote server using ftp <remote server> , it works, it also allows me to transfer files using PASSV mode.

Regards,

Siddhesh

View Entire Topic
manumohandas82
Active Contributor
0 Kudos

Hi Siddesh ,

Not sure with  this , ( May be will help you )

Can you check whether the following is enabled in the  FTP interface configuration in the PI ( By default it is enabled , you may disable )

strictHostnameChecking


1591971 - Added property strictHostnameChecking




Thanks ,

Manu

former_member185954
Active Contributor
0 Kudos

Looks very promising, let me check it and get back to you

former_member185954
Active Contributor
0 Kudos

Hello Manu,

We asked the Third Party hosting the Remote FTP server to amend the FTP server parameters so that it returns the correct IP, which was always going to be plan A.

But I thought the note you provided may have resolved the problem anyways, however since the issue is fixed we didn't apply the note.

So I am marking your suggestion as answered for future reference for others,Thank You.

Regards,

Siddhesh

manumohandas82
Active Contributor
0 Kudos

Thanks Siddhesh .

Happy your issue is resolved  .. Nice weekend

former_member185954
Active Contributor
0 Kudos

Hello Manu,

I checked the note again, applied it for checking whether it resolves the issue, unfortunately it doesn't.

The query is about forcing the adapter to use the OLD IP instead of the new one if the FTP server is responding with a wrong IP.

The flag, only stops PI from generating any certificate errors, it doesn't force the adapter.

For future references, I am unmarking this question as answered, but thanks anyways for your reply.

Regards,

Siddhesh

former_member185954
Active Contributor
0 Kudos

I added a document explaining the same

manumohandas82
Active Contributor
0 Kudos

Good Job Siddesh  to write a doc.

former_member185954
Active Contributor
0 Kudos

Thanks Manu