Showing results for 
Search instead for 
Did you mean: 

Format Problem With Crystal Reports Viewer Group Tree

Former Member
0 Kudos


I have encountered a very annoying problem with my reports when they are being displayed in my Crystal Reports Viewer within my Vb.Net application.

I am using VB.Net 2005 and CR 11.5 release 2.

The problem is that the top level of the Group tree is numeric and it is displayed to two places of decimals. I do not want it to display any places of decimals. Why is it doing this? All of the fields within the report are whole numbers, so I do not know how or why it is doing this. To make it more interesting when viewing the reports outside of the VB.Net app they display properly.

Please help ASAP. I am at my client location and can not figure this out.



Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

The group tree display will follow the default settings, so if you have specified your Group Name in the report to a specific setting, the group tree may not follow it.

You can display a formula as your group tree text, and this will eliminate the problem.

To do so:

- Right click the group header, and choose Group Expert

- Click the options button

- Go to the Options Tab

- Select Customize Group Name Field, and Use a Formula as Group Name

- Click the X-2 button to enter the formula editor

- For the formula, add your field, with the ToText function, ie:

ToText ({table.field} ,0)

That should take care of it.



Answers (1)

Answers (1)

Active Contributor
0 Kudos

This issue has been documented in note 1218802.