cancel
Showing results for 
Search instead for 
Did you mean: 

FISCPER POPULATION ERROR?

Former Member
0 Kudos

FISCPER (Length = 7) field is actually getting it's value from a field 0CREATEDON (Document Creation Date) (Length = 8)at the Data Field Calculation in the ODS .So the data is getting truncated and we are unable to populate the corect value for FISCPER.

There are 2 other fields (0CALMONTH length 6, 0CALWEEK length 6) which are mapped to 0CREATEDON (length = 8).

Please have a look into this problem and do let us know what needs to be done.

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Usually the system can automatically map your date (createdon) on your fiscper on the basis of an automatic time conversion...

But you need to pass in the same update rules a fiscal variant too !

Hope it helps!

Bye,

Roberto

Former Member
0 Kudos

Hi,

as Roberto already mentioned, the fiscal period can only be calculated correctly out of the creation date if you specify the fical variant too. If you can provide the fiscal variant, you can get a automatic conversion. Otherwise you might need a constant (but existing) value for the fiscal variant. If it isn't available in BW, do a upload of the global settings from your r/3 source system via 'rsa1->source-systems', right click on your source system and select 'transfer global settings'.

Siggi

Former Member
0 Kudos

Hi Roberto....

Thanks for the insight, just a more classification in this regard:

1. 0FISCVARIANT we are using as a key field, not as a data field. So, it cannot be included in update rule. Please suggest on this.

Former Member
0 Kudos

Why cannot you include it in update rules?

You should have it for every row in data field !