cancel
Showing results for 
Search instead for 
Did you mean: 

FIORI: SAP Standard tiles not translated

voss
Contributor
0 Kudos

Hi *,

we use FIORI for CRM and have activated several apps (MyAccounts, MyContacts ...). Unfortunately the standard tiles seem to be not translated from DE --> EN.

When starting the launchpad with logon language EN all tiles still contain the German description (Meine Accounts ...). The group is given in German as well (Vertriebsbeauftragter).

As soon as I tab on a tile (Meine Accounts) the head contains "My Accounts" and all the content is shown in EN as expected as well.

The language of the tablet is set to EN.

Any ideas?

Kind regards

Thomas

Tags edited by: Michael Appleby

View Entire Topic
masa_139
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Thomas,

Could you upload the screenshot?

What is support package level for UICRM001? Is it SP03?

Regards, Masa

SAP Customer Experience Group - CEG

voss
Contributor
0 Kudos

Hi Masa,

we are dealing with

UICRM001 100 0003 SAPK-10003INUICRM001 0000 - @6H\QErreicht mit Support Package@ UI für CRM

So yes, it is SP03 with UICRM001.

Regards

Thomas

masa_139
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Thomas,

Please take a look .

Regards, Masa

SAP Customer Experience Group - CEG

voss
Contributor
0 Kudos

Hi Masa,

unfortunately the described procedure didn't solve the problem. The tiles are still shown in DE when logged on with EN.

Regards

Thomas

masa_139
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Thomas,

Is it personalized group or standard group delivered by SAP?

Can you test with these?

+ By clearing browser cache

+ Alter logon, add &sap-language=EN at the end of URL

+ Delete assigned group role and clear browser cache, then assign the group role again.

Regards, Masa

SAP Customer Experience Group - CEG

Message was edited by: Masayuki Sekihara

voss
Contributor
0 Kudos

Hi Masa,

up to now we did not perform any personalizations and enhancements. I am working with standard catalog SAP_CRM_BC_SalesRep.

I've executed the described steps but it did not solve the problem.

I detected that parameter &sap-language=EN is already added when logged on.

Regards

Thomas

masa_139
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Thomas,

Did you add tiles from standard catalog? or Are tiles  from assigned standard group role SAP_CRM_BCR_SALESREP?

Regards, Masa

SAP Customer Experience Group - CEG

voss
Contributor
0 Kudos

Hi Masa,

the tiles are taken from standard catalog with mentioned group role.

Regards

Thomas

masa_139
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Thomas,

Please confirm that you have not set any language in the SICF.

Determining the Logon Language - Components of SAP Communication Technology - SAP Library

Regards, Masa

SAP Customer Experience Group - CEG

voss
Contributor
0 Kudos

Hi Masa,

in case you talk about service "icm_languages" I confirm it.

Regards

Thomas

masa_139
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Thomas,

How about Launchpad Designer? Do you see tiles in DE with EN logon?

Regards, Masa

SAP Customer Experience Group - CEG

voss
Contributor
0 Kudos

Hi Masa,

with logon language EN the tiles are shown in EN in the launchpad designer. Are any settings missing?

Regards

Thomas

masa_139
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Thomas,

I feel there is some cache issue. Please try some of programs.

/UI2/DELETE_CACHE

/UI2/DELETE_CACHE_AFTER_IMP

/UI2/CHIP_SYNCHRONIZE_CACHE

/UI2/PAGE_CACHE_RESET

Regards, Masa

SAP Customer Experience Group - CEG

voss
Contributor
0 Kudos

Hi Masa,

all the reports did not solve the problem. Unfortunately.

Regards

Thomas

masa_139
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Thomas,

How about setting external break points and do troubleshoot?

OData:

+ PAGE_BUILDER_PERS

+ PAGE_BUILDER_CUST

+ PAGE_BUILDER_CONF

Regards, Masa

SAP Customer Experience Group - CEG

voss
Contributor
0 Kudos

Hi Masa,

we checked the handler of the services and the language called is always EN.

Regards

Thomas

masa_139
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Thomas,

Strange. I suggest you to create an incident ticket and report the issue.

Please share the solution when you get.

Regards, Masa

SAP Customer Experience Group - CEG

voss
Contributor
0 Kudos

Hi Masa,

the error was founded in an internal RFC-connection (CRM <-> CRM). There DE was maintained. I left the field blank and the system uses user's logon language.

Thank you for all your support.

Kind regards

Thomas

masa_139
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Thomas,

Thank you for sharing the root cause. It is always difficult to find such a basic mistake.

Regards, Masa

SAP Customer Experience Group - CEG

SK-EA
Active Participant
0 Kudos

These reports resolved my issue. Thanks

agentry_src
Active Contributor
0 Kudos

Hi Thomas V.

Please mark this Discussion with a Correct Answer and Helpful Answer where appropriate.  See http://scn.sap.com/community/support/blog/2013/04/03/how-to-close-a-discussion-and-why   Even if you discovered the solution without any outside contributions, it helps others to understand what the solution turned out to be.

Regards, Mike
SAP P&I Technology RIG

mariama-moura91
Explorer
0 Kudos
HI Masa!
mariama-moura91
Explorer
0 Kudos

Hi Masa!

What RFC have you changed? I'm having this same issue, but the fiori apps instalation are embedded, I can't find any configuration for language under the LOCAL RFC settings