cancel
Showing results for 
Search instead for 
Did you mean: 

fiori add deploy-config cf not working as expected

damovand
Product and Topic Expert
Product and Topic Expert
0 Kudos

Following steps 9, 10 after I go to cd to cpapp/app/risks and type the command fiori add deploy-config cf, the editor behaves differently than what is in the instructions. It does not allow typing the destination name.

I get something the below response with no way to type in the destination name: As you can see Description name has the value "None" and I cannot type anything else.

If I press enter, without entering the destination, then I get an error. I don't know why the editor does not allow any entry.

Just to confirm I perform step 8 without any errors or issues.

Please help identify the root cause. Thank you.

user: risks $ fiori add deploy-config cf
Adding deploy-config to the project.
WARN Add:Deploy-config No VSCode Settings file found.
info Add:Deploy-config Using: @sap/fiori:deploy-config
? Destination name None<br>
? Editing the deployment configuration will overwrite existing configuration, are you sure you want to continue? Yes
Error @sap/fiori:deploy-config cf --base ui5.yaml --config ui5-deploy.yaml 

could not update the "/tmp/a8a4b527a3561ef56d0a1ccfca6931c4.temp.mta.yaml" file; it was modified by another process
Do you need to install @sap/generator-fiori globally?
npm install -g @sap/generator-fiori
OR
yarn global add @sap/generator-fiori

View Entire Topic
Ajit_K_Panda
Product and Topic Expert
Product and Topic Expert
0 Kudos

what is your mta package version?
I believe this is an issue with latest version of mta. can you try setting mta version as below:
npm i -g mta@1.0.4

damovand
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Ajit,

That solved the problem. Thank you very much.

Best Regards,

Leila

beampakorn
Explorer
0 Kudos
hi i use mta@1.0.4 and the problem still there