cancel
Showing results for 
Search instead for 
Did you mean: 

Filtering multiple values

senfpe
Participant
0 Kudos

Hi all,

I've an issue with filtering multiple values of one dimension. I want to filter the dimension "customer_land". All works fine if I choose values like US, GB and DE. Additionally it can be possible that the customer_land is blank. If I want to add the blank value to this existing filter, nothing happens. There are still only 3 filter values (US, GB and DE).

I expect that a multiple filter with blank values is possible because a single filter on this blank criteria works!

Any ideas?

Regards,

Peter

Accepted Solutions (1)

Accepted Solutions (1)

CdnConnection
Active Contributor
0 Kudos

Peter,

     You have data issue, current version of Explorer filters on DATA only.  Couple of way to get around the data issue are:

- Update the SQL in UNX for the Dimension to replace all BLANKS to "No_Data"

- You will also need to fix all NULL records

Best way is to actually fix the Data in the DB but it is not always practical.

Regards,

Ajay

senfpe
Participant
0 Kudos

Hi Ajay,

so I have to rename all rows 'customer_land' = '' into 'No_data' ? It is not a blank but a varchar(0).

Why single filter works and multiple filter not - it seems a bug, or?

Regards,

Peter

CdnConnection
Active Contributor
0 Kudos

Peter,

    It may be a bug.  What version of BI 4.x are you running?   SP? & FP?

The single filter selector is different from multi filter selector.

Regards,

Ajay

senfpe
Participant
0 Kudos

Hi Ajay,

we are on latest Patch 4.0 SP05 Patch 6.

Regards,

Peter

CdnConnection
Active Contributor
0 Kudos

Peter,

    I would suggest fixing the issue by using the work around suggested.  I am part of Explorer Influence council and I will bring you point/bug to the Explorer team to see if it a known issue.

Regards,

Ajay

Please let me know if this helpful.

Answers (0)