cancel
Showing results for 
Search instead for 
Did you mean: 

FileDownload UI - AllowSave option not working

Former Member
0 Kudos
58

Hi All,

I am creating a WD4A application which has an option of file upload/download. The application is working fine while uploading the files. Now when i try to download the files using "FileDownload UI element" the application does not ask me for the option to save the attachment. It tries to open the file in the browser window itself.

I did note that there is a property "Behaviour" under the FileDownload properties. I had tried changing this setting to "AllowSave" but still the reaction is same. As a result if i download a txt file i can see the contents in the HTML page. Similarly if i try to download a DOC file (which has some MS word formatting inside) a HTML webpage with the documents contents mixed with some junk characters open up.

Moreover even after changing this behaviour in properties, the "Field Help" in the application screen (accessed by right clicking on the "Download" element in application screen and selection the option "More Field Help") shows the attribute behaviour as "Auto" instead of the value "AllowSave"!!!

Has anyone faced this issue before? Do we have any other setting for this purpose?

Thanks,

Prasath N

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi Prasath,

I faced a similar suituation like file downloading with filedownload element. For text document I was able to open the text document.When I selected the option allowsave, It asks me with the option like "SAVE" "OPEN" AND "CANCEL" . But this works fine just for 3 days . Then I ran the same program and I got the problem like it doesnt open anything. Then I selected "auto" and then it opens in a browser. I dont know why. Like what you said I cannot open other documents except text document. ie., I cannot open either word or excel or pdf. It opens with junk letters. I dont know why . But when I checked the XSTRING content it is same . But I dont know why it is not working. But still now I am wondering how it is only working fine for txt document and not for work excel or pdf. Some expert can only need to answer this question(where we have to correct our program).

Former Member
0 Kudos

hi prasath....

if you are trying to download an internal table....

always go for gui_download function module for it is very simple.

you can download in any format.

---regards,

alex b justin

Former Member
0 Kudos

Hi,

If you are looking for File Download , then why dont you try this...

<b>cl_wd_runtime_services=>attach_file_to_response</b> method.

Regards

<i><b>Raja Sekhar</b></i>