cancel
Showing results for 
Search instead for 
Did you mean: 

File to IDOC 4.6c (ORDERS05.ORDRSP) PI 7.11

Former Member
0 Kudos
310

Im reading a file through the PI file adapter and writing it to the IDOC adapter into 4.6C.

I have overwritten MESTYP in mapping in the EDIDC40 to (ORDSP) but when the IDOC is received in 4.6 the message type displays as ORDERS not ORDRSP and so the Partner Profile doesnt trigger.


 <ORDERS05>
- <IDOC>
- <EDI_DC40>
  <IDOCTYP>ORDERS05</IDOCTYP> 
  <MESTYP>ORDRSP</MESTYP> 

Any help would be appreciated.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

You need to import the idoc ORDRSP.ORDERS05 and not ORDERS.ORDERS05...

reimport the idoc and change the mapping and test the same ...

HTH

Rajesh

Answers (2)

Answers (2)

Former Member
0 Kudos

Thanks, no comment, I should have realised....

Former Member
0 Kudos

Fellas,

I am having issue with ordrsp idoc.

Currently we are receiving ack from third party for order changes. PI is configured to get idoc xml using HTTP service configured.

After PI gets the xml it calls idoc adapter to create idoc in r/3 system.

ORDRSP.ORDERS05 IDOC is already imported in PI and PI pushes it to r/3 via idoc adapter service. This interface is working in production fine. However recently sterling have started populating another control field which is <MESCOD>. R/3 is creating the idoc but not populating this particular field (MESCOD).

Their is no message mapping in PI to populate any fields. Data comes from 3rd party via HTTP and gets processed using IDOC adapter. Not sure why MESCOD is not getting populated.

Looked at message arriving in PI and can clearly see MESCOD field getting populated with right content.

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

- <ORDERS05>

- <IDOC BEGIN="1">

- <EDI_DC40 SEGMENT="1">

<TABNAM>EDI_DC40</TABNAM>

<MANDT>011</MANDT>

<DIRECT>2</DIRECT>

<IDOCTYP>ORDERS05</IDOCTYP>

<MESTYP>ORDRSP</MESTYP>

<MESCOD>WEB</MESCOD> -


>>

<SNDPOR>SAPP1C</SNDPOR>

<SNDPRT>LS</SNDPRT>

<SNDPRN>EDIGATEWAY</SNDPRN>

<RCVPOR>SAPR1C</RCVPOR>

<RCVPRT>LS</RCVPRT>

<RCVPRN>R1CCLNT011</RCVPRN>

<CREDAT>20120213</CREDAT>

<CRETIM>000242</CRETIM>

</EDI_DC40>

Can someone please guide why would this one field not get populated when IDOC gets created in R/3 system..

Please help..

ta,

Jas

RKothari
Contributor
0 Kudos

Hello,

Have you checked the Apply control records from payload checkbox in Receiver CC?

-Rahul

Former Member
0 Kudos

Yes and it appears in the XML as per the above code segment

RKothari
Contributor
0 Kudos

Hi,

Any specific reason for changing message type???

ORDRSP message type is available with Basic type ORDERS05, you can use this in your mapping.

-Rahul