cancel
Showing results for 
Search instead for 
Did you mean: 

File System Repository: setup failed

junmei
Participant
0 Kudos

We are running <b>Enterprise Portal 6 SP14</b> on w2003

We are trying to set up a file system repository located on W2000.

We have configured all as describes in the administration guide.

KMWindows_System: com.imec.win2000 with alias win2000

network path

Fsmount

Usermapping

properties

securitymanager: w2kSecuritymanager

lookup mode: caseless

windows landscape system: com.imec.win2000 (or Win2000 gives no differences)

but it does not work.

In the logfile we found

#1.5#001321F1F5A9000500000015000017A400040664E9A44C4F#1132930393204#com.sapportals.wcm.repository.manager.generic.security.w2k.W2kSecurityManager#sap.com/irj#com.sapportals.wcm.repository.manager.generic.security.w2k.W2kSecurityManager#marent#462##sapkmdev.imec.be_KMD_9490050#marent#23e61ca05dc311dab336001321f1f5a9#SAPEngine_Application_Thread[impl:3]_29##0#0#Warning##Plain###Failed to get user mapping data for user marent and system com.imec.Win2000com.sapportals.wcm.WcmException: can't get system com.imec.Win2000 from system factory - check landscape configuration

at com.sapportals.wcm.repository.manager.generic.security.w2k.W2kServerConnection.getCredentialsFromLandscape(W2kServerConnection.java:120)

We can generate a search data repository with the data located on the file system.

When we logon in the portal as administrator the search gives us results with files on the file server.

When we logon with a user (mapped domain\user and password)

then no results. The user has access to some files.

What is wronf? Any help would be much appecidated.

Best regards

Luc

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi!

The alias of the system in the portal landscape has to be the same as the name of the system in the CM landscape.

You have chosen win2000 which does not match com.imec.win2000 or Win2000 (case sensitive match!!!).

Everytime I worked with user mapping I named the portal system, the CM system, and the alias identically and

this worked.

The system configured in the repository manager must match the CM system.

bye, Dirk

junmei
Participant
0 Kudos

Hello,

KMWindows_System: com.imec.Win2000 with alias Win2000

The windows landscape system was Win2000.

It does not work.

We changed it into com.imec.Win2000, it does not work.

The case sensitive, this was ok (forgotten in the message)

So any other idea?

Regards

Luc

Former Member
0 Kudos

Hi!

Did you restart the portal after giving identical names to all the systems?

bye, Dirk

junmei
Participant
0 Kudos

Hello,

>> Did you restart the portal after giving identical names to all the systems?

yes.

Regards,

Luc

Former Member
0 Kudos

Hi!

Sorry for asking again, but what I read from your posts is:

Portal landscape system is com.imec.Win2000

Portal landscape system alias is Win2000

CM landscape system is com.imec.Win2000 (resp. Win2000)

Repository manager tries to use com.imec.Win2000 (from the exception)

So, if the repository adresses com.imec.Win2000, the CM system and the alias must be com.imec.Win2000.

If the alias and the CM system are Win2000, the repository must use as well Win2000.

bye, Dirk

junmei
Participant
0 Kudos

Hello,

I check again:

The file system repository: the field Windows Landscape System has as value Win2000.

We will restart the engine with

Portal landscape system alias: Win2000

CM landscape system : Win2000

File repository: Win2000

<i>

"Monday 28/11/2005 I post the results."</i>

The results after resetting:

#1.5#001321F1F5A90021000000080000198C0004069E9C1C4567#1133178202154#com.sapportals.wcm.repository.manager.generic.security.w2k.W2kSecurityManager#sap.com/irj#com.sapportals.wcm.repository.manager.generic.security.w2k.W2kSecurityManager#marent#2131##sapkmdev.imec.be_KMD_9490050#marent#26b039f0600411da95d0001321f1f5a9#SAPEngine_Application_Thread[impl:3]_2##0#0#Warning##Plain###Failed to get user mapping data for user marent and system Win2000com.sapportals.wcm.WcmException: can't get system Win2000 from system factory - check landscape configuration

at com.sapportals.wcm.repository.manager.generic.security.w2k.W2kServerConnection.getCredentialsFromLandscape(W2kServerConnection.java:120)

at com.sapportals.wcm.repository.manager.generic.security.w2k.W2kServerConnection.<init>(W2kServerConnection.java:45)

So still problems. Any suggestions welcome.

Regards

Luc

Message was edited by: Luc M

Former Member
0 Kudos

Hi!

Should work. Please open an OSS for this.

bye, Dirk

junmei
Participant
0 Kudos

Hi,

we created a OSS note.

I post the solution when it is solved.

Regards

Luc

Former Member
0 Kudos

Hi,

Will you please update with the solution for this issue?

Regards,

Arun

Answers (0)