cancel
Showing results for 
Search instead for 
Did you mean: 

FI-AA Delta init Problem

Former Member
0 Kudos

Hello All,

We are trying to initialize Delta (with data transfer) for DSO 0FIA_DS11, 0FIA_DS12 and 0FIA_DS13. It works for 0FIA_DS11 without any problems but 0FIA_DS12 and 0FIA_DS13 always show me a error "Delta update for 0FIA_DS11 is invalidated". The Request says: Type of Data Update "Repeat of the last delta" but that makes no sense because there is not even Delta Init Request in 0FIA_DS12 and 0FIA_DS13.

Any Ideas are welcome!

Please tell me If I missed something or if you need further information. Its my first post and I am not very experienced in writing threads here.

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Problem solved. Thanks.

former_member21257
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Tobias,

Normally to solve the problem you need to reinitialize the load

again, i.e delete all the data from the target and reload from

the source ODS.

However it should be possible to solve the problem by using the

following workaround, if the requests that really have not been

loaded to the target cube are still available in the PSA for

the loads to the ODS 0FIA_DS12 / 0FIA_DS13 .

The steps to take are the following:

1. Delete the request with red status in the target ODS.

2. Delete ONLY the requests from the source ODS which have NOT

been loaded to the target ODS already. If the requests which

you need to delete are available in the PSA for the load to 0FIA_DS12

then these can be reloaded to the target ODS in a later step.

If all requests are already loaded to the target ODS and none

are missing then you don't need to do anything in this step.

3.You now need to delete the existing init request for the data mart

load. To do this in the InfoPackage (just take one if there are several)

reset the delta management in menu'scheduler', 'Init options for

source system'.

4. Now execute an init load without data transfer, in the

InfoPackage set the extraction mode to 'Delta Init w/o data

transfer' and press 'execute immediately'. This will fill RSDMDELTA

with ALL requests contained in the source ODS's changelog at

that time. In other words this process resets the datamart

flag in the source ODS for the requests that have already been

loaded to the cube.

5.Now in this step reload the requests from the PSA to the source ODS

that you deleted in step 1 (if you deleted any requests) .

6.The next datamart delta from the source ODS should load

these requests into the target cube.

Rgds,

Colum

Edited by: Colum Cronin on May 28, 2009 12:30 PM

Former Member
0 Kudos

Hi there,

Are you sure that the deltas of that datasource were deleted for all datatargets before starting the init?

It seems like DSO 0FIA_DS11 didn't have any init, that's why it worked fine, but 0FIA_DS12 and 0FIA_DS13 still have the init flag even if maybe there weren't any data in the DSO.

Create a new infopackage for the init, make sure that in the infopackage you delte the init request from all datatargets. Then make sure that the init will be sent in the infopackage for the 3 DSOs and is marked as init with data transfer.

Try it.

Diogo.