cancel
Showing results for 
Search instead for 
Did you mean: 

failed to connect to system : Odata receiver adapter in sap cpi

0 Kudos

Hi Experts,

We are getting an error while trying to connect to a system from SAP CPI using Odata Receiver Adapter. We are able to connect only if we select Local EDMX as Connection Source but if we select as remote, its throwing an exception as "Failed to connect to system".
Could you please let us know the possible solution for this issue as we do not want to use local EDMX option ?

Also used actual configuration parameters. We do not have location ID so we kept blank.

Accepted Solutions (0)

Answers (8)

Answers (8)

rafaelchagas
Participant

Guys,

You must remember to put the sap-client when is not set on ICF for the OData Service.

Have a nice day.

smitha_gatty
Explorer
0 Kudos

hi Rafael,

Does addition of sap-client help if it is an on-premise connection?

Regards,

Smitha

GoranKovacic
Participant
0 Kudos

Hi Rafael,

I just followed your suggestion it solved my problem with connection ODATA V4 via Cloud Connector to a OnPrem System. Thank you!

PS.: Do not forget to also set the sap-client as Header when performing the real call.

BR
Goran

former_member666312
Active Participant
0 Kudos

Hi Archana,

In that case you will need to use the EDMX way of configuration only and once you are done with the config of query then you can run end to end to test.

Thanks and Regards,

Vijay

0 Kudos

Hi Vijay,

Thanks for responding, currently we are local EDMX only. However in the landscape its working for all the systems except for this one. If we deploy it makes call to cloud connector and its successful. This issue is only while making changes in the query string.

Thanks & Regards,

Archana Vijay

0 Kudos

Hi Archana Vijay,

Was there any resolution on this topic? I have the same issue.

Many thanks

Vinay

former_member666312
Active Participant
0 Kudos

Hi ,

Can you please confirm ,you are connecting to the Internet not the On-Premise Option right?

Thanks and Regards,

Vijay

0 Kudos

we are connecting to on premise and providing the cloud connector location I’d

0 Kudos

Is this issue solved ? Can one of you post here with the resolution , we are getting the same error .

daviddasilva
Active Contributor
0 Kudos

Hi,

Can you try and run a connectivity test from the Monitor tab in Cloud Integration and see what happens? Maybe there is an issue with Cloud Connector setup.

Is it also possible to check the Error Logs in S4 to see if the connection is made but that it runs into an S4-side error.

Kind regards,

David

0 Kudos

Hi mani.kantha.reddy,

Not necessarily, local EDMX the metadeta is referred locally so you must not need to make a call to fetch the metadata.

I would suggest to check on the backend system for issues.

thanks and regards,

Praveen T

0 Kudos

Hi Praveen,

Thank you so much for the response. I checked with my backend S4 team and they have no clue to check further on this issue.
Could you please give more insight from S4 perspective, on what needs to be checked, so that i can assist S4 team on the same ?

0 Kudos

Hi mani.kantha.reddy,

could you please check if the user has sufficient roles.

hope that helps !

thanks and regards,

Praveen t

0 Kudos

Hi Praveen,

Thank you for the reply, It works fine when we use local EDMX and able to get the data from on-premise system, so i believe the user must have sufficient roles to fetch the data.

kuznetsov_in2
Explorer
0 Kudos

you should write down real hostname here, at this query generation dialog

0 Kudos

Hi llya,
Thanks for the reply.
We also tried with virtual host/name(on-premise system) in the address parameter but still we are getting the same exception.

BR,

MK

asutoshmaharana2326
Active Participant
0 Kudos

Dear Mani,

Kindly do not use the simple expression, try to use all the actual configuration in address, location Id and credentials name while using connection source remote.

-Asutosh

kuznetsov_in2
Explorer
0 Kudos

Of course anyone can user ${..} at IFLOW channels but it doesn't work at Model operation.

0 Kudos

Hi Asutosh,

We have also tried with actual configuration in Address and credential name(We dont use location ID) but still getting the same error.