cancel
Showing results for 
Search instead for 
Did you mean: 

Failed to connect backend system

Former Member
0 Kudos

Hi Experts,

I am a BW Consultant working on Portal & Visual Composer (7.0)

As a Developer i got SAP_ALL & SAP_J2EE_ADMIN roles in BW and System Admin and VC role in Portal.

In Portal Created/Published iviews for BW Queries (Transaction) and Published them to a role (role1) in portal.

In Visual Composer i developed Dashboard reports on BW Queries ,made them public and deployed them to a portal role(role 1) in portal.

I assigned portal role to my self and tested the queries and dashboards in portal everything is working perfectly.

In VC i can see 3 different systems defined in Portal

I created a Test user (with profile of end user) in BW,Testuser is authorised to view all the reports in BW and All data in all data targets and in portal testuser is assigned with Role1 and VC Role.

(Note: In BW Testuser doesn't had J2EE_ADMIN role).

Portal:

When i login to portal as testuser and tries to execute the BW Queries (Transaction) and it working perfectly.

When i tried to execute Dashboard reports developed in Visual Composer it gives me an error

"Failed to connect backend system.Check your system definition and user priviliges"

In Visual Composer i logged in as testuser (as test user got VC role assigned) i can't see any list of avaliable systems under "Find Data"

When i modified testuser profile in BW and updated with SAP_J2EE_ADMIN then i can execute the dashboard report but at the same time testuser got more than what he should have like user admin,system admin...etc

I searched the sdn and find some similar threads ...but nothing was useful

Please update me what went wrong and how to fix this...

Thanks in advance

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

Please check the permissions on your system object. This issues is from Portal itself not BW backend.

System Administration->System Configuration->System landscape->Browse for the System Object that has been used in your VC->right click to open the permissions.

Check for the permission for eu_role/everyone group. These should have alteast "read"permission on the System Object. If this permission is missing add up here.

By default all users fall in "everyoone' group, so I suggest adding 'read' permission to this group itself.

Hope this helps,

Thanks,

Vamshi

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi check the permission of testuser in portal.

right click the role and check the permission of enduser whether he has access or not?

Koti Reddy