cancel
Showing results for 
Search instead for 
Did you mean: 

Failed data processing did not complete

Former Member
0 Kudos

Hi. We have recently moved our Vendor project from the development are to the Production area. The project was therefore exported from Development and imported into the Production project. Views are created across tables and rules are bound to these views. I run any tasks to calculate the scores and the tasks complete successfully. I then go to the Rule Results tab in the work space and open any view to look at columns with failed records. I then clink on the column with failed data and it shows the failed records on the right hand side of the screen. I then click on view more failed data and get the following error "Failed data processing did not complete". I can find no link on this error. Does anyone have any suggestions?

View Entire Topic
kerryjones
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Colleagues,

Let me share my experience with this issue in hopes it save someone time researching it. IS 4.2 sp 5 is installed in my QA and Prod environments. I had to migrate two rules from P back to Q, and was expecting no issues since both rules ran successfully in Production. However, I received different error messages on each of the rules: Data is not available and “Failed data processing did not complete”.  The error appears to be tied to the views the rules are bound to.  It’s easy to fix by creating a copy of the view and rebinding the rule to the new view.

The steps below show how to recreate the problem and correct it.

Steps to recreate the problem:

  1. Export rules from source environment,
  2. Import rule, task, view, and rule binding into target environment.
  3. Run rule in the target environment. Both rules complete successfully.
  4. Click “View More Failed Data” (to export the data to a spreadsheet)
  5. Received error messages on both rules.
    1. “Data is not available.”
    2. “Failed data processing did not complete.”

              

Steps to correct the problem:

  1. Delete the rule binding,
  2. Delete the task,
  3. Copy the View,
  4. Rename the copied view,
  5. Rebind the rule to the new view,
  6. Recreate the task,
  7. Rerun the task and it should work.

Root Cause:

It’s worth mentioning I believe the root cause of this issue is these rules were first created in the QA environment, then migrated to Production where additional edits were applied. When migrating the rules backwards from P to QA I tried it using the “Overwrite Existing Objects” Import options; and I tried again by importing by deleting the Rules, Rule Bindings, Views, and Tasks in QA before importing these same objects from production. The error messages received were the same. My guess is that the imported view either did not successfully overwrite the old view, or the “View More Failed Data” button is still linked to the old failed data table created when the rule was originally created in QA.

Hope this helps,

Kerry

0 Kudos

Hi All,

I am getting the same error in IS 4.2 production.

As it is a prod sever I can not do any editions/deletions.

Please suggest...

Thanks & Regards,

Chaitanya.P

0 Kudos

Hi chaitanya,

Can you try to import the same job, but with a different view? This might force IS to create a new failed records database.

0 Kudos

HI Vitali,

Thanks for the suggestion.

But I can not import the job now.The job has been moved to prod long back.This was working fine earlier.Since 1 week it is throwing this message.

I can not change the view and re import the job now.(This needs to go for high level approvals in such case which is not possible at present.)

Thanks,

Chaitanya.P