cancel
Showing results for 
Search instead for 
Did you mean: 

Exception of type 'System.OutOfMemoryException' was thrown, when try to filter row field.

Former Member
0 Kudos

Hi All,

When I try to apply filter by member on a row field in Analysis Office 1.4, I am getting below error and also data source and other details will be cleared out from Analysis tab. In AO User settings, maximum number of members displayed in filter dialog is set as 1000 and I have more than 1000 members also. Anyone faced such an issue?

Any solution or thoughts will be helpful.

Thanks in Advance

-Rakesh

Accepted Solutions (0)

Answers (3)

Answers (3)

david_stocker
Advisor
Advisor
0 Kudos

Hi Rakesh,

My registry question was because I read your email in a way as to understand that this was happening when you open the filter dialog.  In any case, there is no obvious reason why you should be experiencing this. 

You should open an OSS message for this on component BI-RA-AO-XLA, so that when it is resolved we can keep an OSS Note for it.  Please attach the Analysis logfile and the reproduction protocol as well.

Cheers,

Dave

Former Member
0 Kudos

Hi Dave, Vinod, Bharath,

This issue was resolved, after I applied Analysis 1.4 SP01 in my machine.

Now, if it has small number of members in filter it will show like as usual below.

If the filter has large number of members it is show like below.

When we click on the Add button it will show the list members in another pop-up window and it is faster and not throwing memory error.

Thanks a lot for all of you have spend your time and effort on this issue to help me..

Thanks and Regards,

-Rakesh

david_stocker
Advisor
Advisor
0 Kudos

Hi Rakesh,

Have you enabled the Mass Data variant of the member selector?

I'd like to know which of these scenarios is true:

#members > max# & HKEY_CURRENT_USER\Software\SAP\AdvancedAnalysis\Settings\Selector\EnableMassDataSelector = "True"

-or-

#members > max# & HKEY_CURRENT_USER\Software\SAP\AdvancedAnalysis\Settings\Selector\EnableMassDataSelector = "False"

Cheers,

Dave

Former Member
0 Kudos

Hi Dave,

Thanks for your replay. I didn't have 'EnableMassDataSelector' variable in my registry, I have searched through the entire registery in my machine.

I have path up to "HKEY_CURRENT_USER\Software\SAP\"  below that "AdvancedAnalysis" folder is not available.

I have found path like "HKEY_LOCAL_MACHINE\SOFTWARE\SAP\AdvancedAnalysis\Settings" in my registry, but don't have "Selector" folder under that.

I am a BO Analysis Office user. I am using below versions of software's.

BO ANALYSIS 1.4

BOBJ 4.0 SPS 4 PATCH 5

SAP NETWEAVER 7.01 SP 8

BW 7.01 SPS 5

Do I need to update any patch to set-up this variable in my machine?

Any comments or thoughts will be helpful.

Thanks in Advance,

-Rakesh

david_stocker
Advisor
Advisor
0 Kudos

Hi Rakesh,

You can set registry variable with the registry editor.  It should not be a problem that it is not set, but it might be a bug and this is why I'd like you to set it.

Cheers,

Dave

Former Member
0 Kudos

Hi Dave,

Thanks for your replay. Since I don't have the path mentioned by you in my registry, where (path) should set this in the registry? If it is a bug, any idea why it is happened?

Thanks in Advance,

-Rakesh

former_member182346
Active Contributor
0 Kudos

Are you trying to fetch huge data into your analysis report ?

Please try and see if you get a less data set, still issue exist or not.

We got such error messages when I was using Analysis 1.3 and only conclusion we got that time was large data set cause such system out of memory issue.

There is one table in BW (forgot the name) which define the data volume also check the REGEDIT setting on your machine.

Go to Start --> Run --> REGEDIT --> Current User --> Software --> SAP  --> Analysis

here you can define the number of cell limit try and see if it works.

Please refer below help doc - Page No 19.

Thank-You.

Regards,

VB

bharathsap
Employee
Employee
0 Kudos

Hi Rakesh,

This looks like a  memory issue in JVM.

Open SapDesignStudio.ini file from below location (as Administrator):

C:\Program Files (x86)\SAP BusinessObjects\Design Studio

Increase the heap and Perm Size as mentioned below:

-Xmx1024m

-XX:MaxPermSize=512m

Save the file as administrator. (If the system doesn't allow you to save it in Program files, then save the file in desktop and then copy over)

Issue may be solved.

Note that this setting will affect the performance of other applications using JVM.

Java Virtual Memory has a limited space. So, the situation is unavoidable.

Regards,

Bharath

Former Member
0 Kudos

Hi Bharath,

Thanks for your replay, I would like to inform you that I don't have "Design Studio" folder in the given location. I am sorry, I forgot to mention that I am a BO Analysis (MS Excel) user. Did you mean these settings to configure in server?

Thanks in Advance,

-Rakesh