cancel
Showing results for 
Search instead for 
Did you mean: 

ESS Personal Information not working

Former Member
0 Kudos
419

Dear All,

Here we have ECC 6 and EP7 SP10, we have uploaded BP ESS 1.0 SP 7.

For ESS Personal Information workset, iViews for Address, Bank Information, Family Information and Personal Data is showing a page in which it is given steps which are

1 Overview 2 Edit 3 Review and Save 4 Confirmation

Previous Step Exit

And also in SPRO setting for Personal information under ESS head is missing

Employee Self-Service-->Service-Specific Settings --> Personal Data , there is no personal Data link.

Kindly help me what needs to be done for Displaying iViews of Personal information and getting the link for Personal Data in SPRO under Employee Self Service.

Regards,

Sidhartha Chatterjee

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Sidhartha,

For SPRO, are you able to see

Employee Self-Service-->Service-Specific Settings -->Own Data?

Can you elaborate on exact issue you are facing on portal side?

cheers~

avadh

Former Member
0 Kudos

Dear Awadh,

I am able to see Own Data in SPRO.

Issue is that while running Personal Information --> Address iView, the page which is being shown is like this

-


[1] -


[2]--


[3]
[4]
--


Overview Edit Review and Save Confirmation

<Previous Step> <Exit>.

and no data is being Displayed.

The same is the case for other iViews of Personal Information like Bank Details and Family Details.

But for Personal Data iView it is giving this error

"<b>failed to create or init instance of model 'com.sap.xss.hr.per.in.pdata.model.HRXSS_PER_P0002_IN' in scope APPLICATION_SCOPE with instanceId 'null'"</b>.

kindly tell me what needs to be done to resolve this issue.

Regards,

Sidhartha Chatterjee

Former Member
0 Kudos

Hi Sidhartha,

We didn't faced this specific error. But we did face issues in personal information. The reason was that Personnel Area/Sub Areas of the users in SAP was configured to India, correspondingly there is no standard ESS persinfo applications for India.

We resolved it by using "Reuse Country-Specific Applications" under tab 'Own Data' in SPRO, and used the persinfo services for Germany(DE) instead.

Since the error you are facing is referring to model data for IN, may be the reason is the same as above.

cheers~

avadh

Former Member
0 Kudos

Dear Awadh,

Can u be more ellaborative on the same.

I checked the entry in SPRO Own Data, and there are entries for both India and Germany,

Now can u tell in details how do i map Germany Address with my EP.

i mean where and what change needs to be done.

Regards,

Sidhartha Chatterjee

Former Member
0 Kudos

Hi,

Check the help file against the tab "Reuse country specific applications". There is an example given there.

Also check SAP notes 936179 and 953852.

cheers~

avadh

Former Member
0 Kudos

Dear Sidhartha,

Do you manage to solve your problem. I am facng the same problem as well. Would you mind to tell me what have u done to solve it?

Thanks

Regards,

Bryan

Former Member
0 Kudos

Dear Bryan,

For this personal information to work u can perform below mentioned steps.

Step 1:

Update ur SP level to SP10 and above

SP level for ESS Core application, ESS Business Package and XSS Framework.

After update of this personal information should work.

If it does not work then

Perform Step 2.

Step 2:

Create Transaction iView for Personal Data (PZ13), Bank Information (PZ03), Address Details (PZ02) and Family Details (PZ12).

Hope this will solve the problem.

Regards,

Sidhartha Chatterjee

Former Member
0 Kudos

Dear Sidhartha,

I am on EP 7. Anyway to create an transaction iView.

Btw do you manage to solve the following issue?

SPRO setting for Personal information under ESS head is missing

Employee Self-Service-->Service-Specific Settings --> Personal Data , there is no personal Data link.

Thanks

Regards,

Bryan

Former Member
0 Kudos

Any one with a solution here? I seem to have the same problem with the personal information ( and others ) that there is no data on the screen. Only an exit button.

Kind regards

Reinhard Sportel

Former Member
0 Kudos

Hi Reinhard

I have the same problem, did you solve it?

Regards

Sharadha1
Active Contributor
0 Kudos

Hi Sidhartha,

Is there any record available for the employee for the infotype 0002?

Regards,

sharadha

Former Member
0 Kudos

Dear Sharadha,

Records are maintained for the employee in the infotype 0002.

As if i create Transaction iView for Address (Transaction : PZ02) then it is working fine and it is showing me the desired result.

So the problem is not due to records.

there is something else.

Regards,

Sidhartha Chatterjee