Showing results for 
Search instead for 
Did you mean: 

Error while executing PAL procedures in SAP HANA!

Former Member
0 Kudos

Hi Guys,

When I am executing any of the procedure from PAL library, i get an error:

"Could not execute 'CALL palLnR(DATA_TAB_460, "#CONTROL_TAB_460", RESULTS_TAB_460, FITTED_TAB_460, ...' in 295 ms 570 µs . SAP DBTech JDBC: [2048]: column store error: search table error:  [2620] executor: plan operation failed;required data for execution not found" .

Note: I have created wrapper for the above mentioned procedure.I checked other procedures as well, they produce the same error.

I also have AFL_SYS_AFL_AFLPAL_EXECUTE role assigned to my user.



Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Sushant,

Which revision are you working on?

There is an additional message in the error :  [2620] executor: plan operation failed;required data for execution not found.

Hope you have verified that data is present in the input tables and you took care of null values !



0 Kudos

Hi Sushant,

Apparently this is a bug in Hana/Pal. You need to

  • Restart the Hana instance again
  • Re-create afl_wrapper_generator procedure using SYSTEM
  • Grant your user execute on afl_wrapper (grant execute on system.afl_wrapper_generator to your_user)

Then you won't get this error again.



Former Member
0 Kudos

Thank you for your reply, I was getting this exact error and a restart solved my problem.

Former Member
0 Kudos

I have a related but a slightly different question.

When I tried a very large table with PAL's Apriori procedure, the procedure never stop.

How do I terminate this Apriori procedure?



0 Kudos


If you are running the AFL procedure from the SQL console then - in the "HANA development perspective " of Eclipse IDE/HANA studio - there's view to show Job Log & Progress - One can stop SQL action by clicking the Red button - Cancel operation indicator - when the SQL command is running "