cancel
Showing results for 
Search instead for 
Did you mean: 

Error while deploying from NWDS

Former Member
0 Kudos
53

Hi,

i am getting the following error while trying to deploy a PAR file from NWDS through export.

PAR upload failed:C:\Documents and settings\Trials\Trials.par

Please check the userid and password.

i cross checked the userid and password.both are correct. the same par file is deployed successfully in other servers.

this error occurs only for PAR file deployment. other applications like webdynpro and all are deploying successfully.please help.

/* useful inputs will be rewarded*/

Regards,

Art Tech.

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi,

Login to portal using admin user id and after successfull login enter the following url http://hostname:portnumber/irj/go and try uploading the par file from the desktop under "Please specify a Portal Archive file (PAR) and press "upload" to store it into the PCD.".

Regards,

Vinoth.M

Former Member
0 Kudos

Hi All,

Thanks for ur responses.

To Sahu:

Yes the user id has system admin role.

To Ramani:

I know that we can upload the PAR from portal itself as u said but i want to know the cause of my problem. why i am not able to do it from NWDS.

To Vinoth:

As i said i want to upload it from NWDS only.

i want to inform onething to all of u . we thought that it may be problem in SDM. so we checked SDM also. in that a process (deployment) is still going on. so we r not able to enter into it. it is like a infinitive for loop. so, that may be the cause which doesnt allow other deployments.

Can any one tell me how to kill that process. it is something relevent to J2ee engine administration i hope.

What i mentioned above is only our decision , we are not sure that whether it is the exact reason or not. so if anyone encountered the same problem and solved please guide me or any docs related to this also will be helpful.

Regards,

Art Tech.

Former Member
0 Kudos

Hello Art Tech,

Try to use an user which is having the super admin role.

Secondly in NWDS go to window->preferences->workbench->proxy needs to be disabled. When u install NWDS it comes by default.

This should definately work. Also plesae do a syntax check because if there are errors in the par file it will not be uploaded.

Also have a look at this thread:

regards

Atul Shrivastava

PS:Award points if helpful.

Former Member
0 Kudos

Hi Atul,

Thanks for ur response.

As i said already my user has super admin role and proxy settings also in disabled mode only. i think this is not the cause.

As i mentioned in my last post it might be caused due to j2ee/sdm problem. so please gothrough my last post and give me a solution if u have for that.

Regards,

Art Tech.

Former Member
0 Kudos

HI,

uncheck the deploy parfile and export the par file

log in with ur userid and pwd and if your having the Javadeveloper role -->

portalArchieveandremover-->upload the par file and there u can deploy from here

letme know if there are any queries

Thanks&regards,

ramani

Former Member
0 Kudos

hey art,

To deploy webdynpro application in portal ,you need SDM password and to upload the par file you need the System Administrator role.

So there is no link, why you are able to deploy the Webdynpro and not able to upload the PAR file.

The userID, which you are using for uploading the par file, should have the System Admin role.

Thanks,

sahu