cancel
Showing results for 
Search instead for 
Did you mean: 

error while creating a BSP application

Former Member
0 Kudos

Dear Experts,

I am new to BSP applications. I am trying to a create a BSP application in minisap following the steps given in help.sap.com. However, when i tried to test the application, it gives me the following the error.

"

SAP Note

The following error text was processed in the system:

BSP Exception: the Application Name ztutorial_1 in URL /sap/bc/bsp/sap/ztutorial_1/default2.htm?sap-client=000&sap-sessioncmd=open is invalid.

Error type:

Your SAP Business Server Pages Team"

can anybody suggest me what I should go about this error.

Your help will be greatly appreciated.

Thanks!

Babu.

Accepted Solutions (1)

Accepted Solutions (1)

raja_thangamani
Active Contributor
0 Kudos

Hi,

YOu need to configure the FQDN etc..

Look at the blog by Raja D..

<a href="/people/durairaj.athavanraja/blog/2005/08/21/running-your-first-bsp-application-in-sap-netweaver-04-abap-edition--nsp your first BSP application</a>

This will solve your problem.

<i>* Reward each useful answer</i>

Raja T

Message was edited by:

Raja Thangamani

Answers (3)

Answers (3)

Former Member
0 Kudos

WAPD <bsp application name>

WAPP <page.htm>

were selected instead of only 'WAPP <page.htm>' at the time of activating the BSP application.

The problem was solved.

Former Member
0 Kudos

Hi,

I am also getting the same error where to resolve this issue regarding WAPD and WAPP. Please give me steps to resolve this.

Thanks

Hardik Gandhi

Former Member
0 Kudos

I went to se80>utilities>BSP and removed the entries in

LOG,

Application server

and port number

Now i see the following URL.

http://cintas.mycompany.com:8000/sap/bc/bsp/sap/ztutorial_1111/default.htm?sap-client=000&sap-sessio...

athavanraja
Active Contributor
0 Kudos

now is it working?

Raja

Former Member
0 Kudos

Hi Durairaj,

it is still not working and giving same error.

could you help me?

athavanraja
Active Contributor
0 Kudos

is all the relevant nodes under default_host are active? just RMB on default_host and deactivate again RMB clik on default_host and activate, in the resulting popup choose the tree icon button.

after this try running your application. if you still get error message, post the exact error message you see on the browser . (before running the application, in your browser go to tools->internet options->advanced and uncheck the chk box "show friendly http error messages")

Regards

Raja

Former Member
0 Kudos

I did the above changes, n still see the same error.

The warm up application from SAP, tutorial_1.htm is working fine.

The URL for the above BSP application is

http://cintas.mycompany.com:8000/sap(bD1lbiZjPTAwMA==)/bc/bsp/sap/tutorial_1/default.htm

why my BSP application is not working

athavanraja
Active Contributor
0 Kudos

what error are you getting? what do you see in the browser when you run your application. whats the url you see, when you run your application.

Regards

Raja

Former Member
0 Kudos

Raja:

This is error I see now,

Business Server Page (BSP) error

What happened?

Calling the BSP page was terminated due to an error.

SAP Note

The following error text was processed in the system:

BSP Exception: the Application Name ztutorial_1 in URL /sap/bc/bsp/sap/ztutorial_1/def.htm?sap-client=000&sap-sessioncmd=open is invalid.

Error type:

Your SAP Business Server Pages Team

I created a pagewith flow logic. i copied the layout code from SAP bsp application 'tutorial_1'. There might any errors in code?

thanks

Former Member
0 Kudos

http://cintas.mycompany.com:8000/sap/bc/bsp/sap/ztutorial_1/def.htm?sap-client=000&sap-sessioncmd=op...

above is the url.

port number should be 8000 or 1080. for http it shold be 1080 right. why i see 8000. how should i change the port.

athavanraja
Active Contributor
0 Kudos

i dont think port is the issue.

do you have a page called def.htm in your application

is your service active in transaction SICF

Raja

Former Member
0 Kudos

Thanks for replying Raja.

I followed the steps described in the thread. But still I am at the same error.

from the thread,

according step 6, i can not perform save and activate properly. I did not see the activate button in those screens. when i pressed 'back button' it prompted for activatoin, and i activated and restarted the computer and NSP according step 7.

In step 8, i typed SICF and RMB the default_host, it is already activated.

I followed the rest of the steps, tried to test the BSP application, it gave me the same error though.

what should be done?

Thanks!

athavanraja
Active Contributor
0 Kudos

what is the url you see in the address bar of the browser? when you test the application.

Regards

RajaDA

Former Member
raja_thangamani
Active Contributor
0 Kudos

It should be

http://domain_name.com:8000/sap/bc/bsp/sap/ztutorial_1/default2.htm?sap-client=000&sap-sessioncmd=op...

domain_name is like kind of website name. Did you look at the link which i sent you how to configure Fully qualidified domain name.

<a href="/people/durairaj.athavanraja/blog/2005/08/21/running-your-first-bsp-application-in-sap-netweaver-04-abap-edition--nsp your first BSP application</a>

<i>* Reward each helpful answer.</i>

Raja T

Message was edited by:

Raja Thangamani

Former Member
0 Kudos

I see the following

after going through utilities>import profiles>of active servers.

Apparantly, some errors are seen in 'Display Profile Check Log'.

Did it happen for you guys in transaction RZ10.

Import the start and instance profiles of all active servers

The following default profile is imported:

cintas_NSP_00:C:.PFL

The following instance profiles are imported:

cintas_NSP_00:C:_DVEBMGS00_cintas

The following start profiles are imported:

cintas_NSP_00:C:_DVEBMGS00_cintas

Log for the import of profiles

Profile import executed correctly

Complete check of instance profiles and a default profile

Log for default profile , Single check

Profile name : DEFAULT

Physical profile name : C:.PFL

Check on server : cintas_NSP_00

Unknown parameter dbms/dbadminurl , a check cannot be performed

Log for instance profile , Single check

Profile name : NSP_DVEBMGS00_CINTAS

Physical profile name : C:_DVEBMGS00_cintas

abap/buffersize is smaller than default 150000

alert/MONI_SEGM_SIZE is smaller than default 40000000

enque/table_size smaller than minimum 4096

Unknown parameter rspo/local_print/method , a check cannot be performed

rsdb/ntab/ftabsize smaller than minimum 3500

rsdb/ntab/sntabsize smaller than minimum 1000

rsdb/ntab/irbdsize smaller than minimum 1500

rsdb/cua/buffersize is smaller than default 3000

rtbb/buffer_length is smaller than default 10000

rtbb/max_tables is smaller than default 500

sap/bufdir_entries is smaller than default 2000

Language , not installed

zcsa/presentation_buffer_area is smaller than default 4400000

zcsa/calendar_area is smaller than default 500000

zcsa/table_buffer_area is smaller than default 30000000

zcsa/db_max_buftab is smaller than default 5000

ztta/diag_area is smaller than default 250000

rdisp/PG_SHM is smaller than default 1200

rdisp/ROLL_SHM is smaller than default 1024

rdisp/appc_ca_blk_no is smaller than default 100

auth/new_buffering invald value 1

Unknown parameter dbs/ada/schema , a check cannot be performed

Log for instance profile , Complete check

Profile name : NSP_DVEBMGS00_CINTAS

Physical profile name : C:_DVEBMGS00_cintas

Log for entire check

No errors found

Complete check of start profiles

Log for start profile , Single check

Profile name : START_DVEBMGS00_CINTAS

Physical profile name : C:_DVEBMGS00_cintas

Instance DVEBMGS00 for system NSP not configured

Log for start profile , Complete check

Profile name : START_DVEBMGS00_CINTAS

Physical profile name : C:_DVEBMGS00_cintas

Log for start profile list

No errors found

raja_thangamani
Active Contributor
0 Kudos

Yes it will show the some errors in red color in the log But ignore them & configure as it show in the blog & re-start the SAP.

Let us know how it goes.

<i>* Reward each useful asnwer</i>

Raja T

Former Member
0 Kudos

dear folks,

I am getting the same error. I don't see the domian_name in the URL of the BSP error page.

I can not figure out the problem. could you guys give me hand on this.

that will be greatly appreciated.

Thanks!

The following is the code for 'LAYOUT'

<%@ page language="abap" %>

<html>

<head>

<title>SAP Web Application Server</title>

</head>

<body>

<center>

<h1>Welcome to the</h1>

<h2>SAP Web Application Server!</h2>

<% do 5 times. %>

<font SIZE = <%= sy-index %>>

<p> <center>

Hello World!

</font>

<% enddo. %>

<p>

<img src="../PUBLIC/Tutorial/scalability.jpg">

</body>

</html>

raja_thangamani
Active Contributor
0 Kudos

Can you post your url here after chaning the profile?

what value did you mention in "icm/host_name_full"?

btw, did you re-start the SAP WAS?

Raja T

Message was edited by:

Raja Thangamani

Former Member
0 Kudos

This is the URL:

http://localhost:8000/sap/bc/bsp/sap/ztutorial_1111/default.htm?sap-client=000&sap-sessioncmd=open

and

icm/host_name_full -


cintas.mycompany.com

Thank You!

Former Member
0 Kudos

I restared the computer and WAS too.

raja_thangamani
Active Contributor
0 Kudos

It should not show as "localhost", it should show as cintas.mycompany.com

Did you change your host file on your computer? If not do the below steps:

Go to C:\WINDOWS\system32\drivers\etc and edit hosts file (open with notepad)

Enter 10.10.0.10 <computername>.mycompany.com as shown in the above picture and save the file.

After this restart the SAP Server.

Raja T

Message was edited by:

Raja Thangamani

Former Member
0 Kudos

Raja:

the steps mentioned in the blog: Running your first BSP application. utmost care was taken in implementiong those steps.

As I said before: in SICF, default_host is grayed out when right click mouse button to 'activate' it. it is automatically activated I guess, but in it is mentioned in the blog to do it manually.

i can see icm/host_name_full as '<computername>.mycompany.com' but when BSP is run, it is seen as 'localhost.8000'.