cancel
Showing results for 
Search instead for 
Did you mean: 

Error While Activating Attribute View

Former Member
0 Kudos

Hello Experts,

I am trying to Save and Activate my simple attribute view but getting below error. Looks to be an privilege issue but not sure how to resolve it.

Message :

  Activation ID: XXXXX (Repository: User is not authorized to execute specified operation;User 'XXXXXXXX' has no authorization, privilege: 'REPO.MODIFY_CHANGE'!)

I have masked the Activation Id and User name with "X".

Can someone help me on this?

Regards

Niraj

Accepted Solutions (1)

Accepted Solutions (1)

pfefferf
Active Contributor
0 Kudos

Hello Niraj,

the missing system privilege "REPO.MODIFY_CHANGE" indicates that you have "Change Recording" activated on your system and you are not allowed to modify a change (list).

You need the required system privileges to proceed. Consider also the other necessary system privileges for change recording depending on your needs (System Privileges (Reference) - SAP HANA Security Guide - SAP Library).

Regards,

Florian

Former Member
0 Kudos

Hello Florian,

I will check this and update you on this.

Regards

Niraj

Former Member
0 Kudos

Hi Florian,

Could you please help me with the syntax or command have the access to those system privileges?

Regards

Niraj

pfefferf
Active Contributor
0 Kudos

In the user management a privileged user has to assign the required system privilege (either directly or via a corresponding role which is defined upfront; depending on your setup).

Here you can see it in the web based tooling for the user management:

Former Member
0 Kudos

Thanks Florian!! that solved my issue though I was not able to modify the privilege to myself as it showed error

Could not modify user 'ID534608'. SAP DBTech JDBC: [7]: feature not supported: grantor and grantee are identical

While doing so but Super user assigned me those privilege and I am good. Thanks for your time.

Would it be possible to explain the above error that I got while assigning privilege to myself.

Regards

Niraj

Answers (1)

Answers (1)

0 Kudos

Hi Niraj,

you may need to grant select rights of the tables used in your attribute view to the _SYS_REPO user with the following statement:
GRANT SELECT ON SCHEMA "<your_schema>" TO "_SYS_REPO" WITH GRANT OPTION

Kind regards

Christian

Former Member
0 Kudos

Hello Christian,

I tried this option but no luck. Thanks for your help.