Showing results for 
Search instead for 
Did you mean: 

Error when linking to DB (DAO) Error Code 0xbd4

Former Member
0 Kudos

Hi forum,

I'm currently experiencing an issue with my brand-new installation of Crystal Reports XI when trying to connect to a database to preview my report.

I recently had to format and reinstall the OS. Prior to this, it was working fine, however now it doesn't work.

I can no longer link CR to any database (MS Access) and thus, cannot get any work done.

Any help would be greatly appreciated

Here are the specs of what I'm running:

Crystal Reports XI (

Windows 8 Pro 64bit

MS Office 2013

i5 processor

8GB memory


Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos


XI is end of life a long time ago and before Windows 8 so you are likely missing a bunch of 32 bit DAO drivers. But it's not supported so hard to say what is missing. Make sure there is a 32 bit DAO driver on your PC.

A quick check by opening up the 32 bit ODBC Administrator and Drivers tab to see if this is there:

If it's not then that would be why and not sure if MDAC installs it or if MDAC is installed on Windows 8. Try searching MSDN for info on using 16 bit JET engine on Windows 8.

You can upgrade to CR XI R2 ( version 11.5 ) for free, use your XI keycode to install it, it's not supported on Windows 8 either but it's supported on Windows 7 so it could  be closer to working.

Install first:

Then install this without running CR between installs.

To be supported on Windows 8 get Crystal Reports 2013.


Former Member
0 Kudos

Thanks, I downloaded R2 SP4 and installed it - no difference.

Previously I had Windows 8 running CRXI and it worked fine, so I'm not sure why this time around it's any different. I will download the other file and run it too. Thanks.

Former Member
0 Kudos

Installed all of the above and still nothing. I'm going to try to reinstall MS Office 2013 to see if it makes a difference.

0 Kudos

Search MS for MDAC, that's what you want...

Are you using Office 2013 64 bit by the way? Because if you are then that's likely the problem. You can't have a 32 bit DAO on the same PC with 64 bit MS Office.

May explain why it's not working and you don't have it.


Former Member
0 Kudos

Thanks Don, but this isn't the case. It's 32-bit office. I found a workaround for this issue though.

Here is what I found:

There is a file called System.MDW, and it seems to be some sort of global template (kinda' like Normal.DOT). Located in C:\Users\[User Name]\AppData\Roaming\Microsoft\Access directory.

Even though I am an Admin user on this local computer, I still experience problems with permissions every now and again (Windows 8 Pro... hehe).

Either way, I moved this file to a different location that isn't hidden and changed the location where the computer is looking for it within the registry - I found it by searching for System.MDW.

Located it at:

HKEY_USERS\S-1-5-21-3606970038-3727448175-1132535453-1001\Software\Microsoft\Office\15.0\Access\Access Connectivity Engine\Engines

Once I changed the path for the location of System.MDW, Crystal Reports now accepts the databases and allows me to preview and modify my reports.

Thanks Don for all your assistance!

0 Kudos

Ah, very interesting... When you create a DSN to Acess there is an option to use the system.mdw file but typically you leave it blank and not use it unless you put security on the MDB then it's required.

So this must be somethign that Windows 8 is doing for you, very thoughtful of MS to do things you don't want done.. lol

Just a reminder also, CR 10 is not supported on Windows 7, 8, 8.1 or anything higher...

Thanks for letting everyone know... still not supported but may help others.


Answers (0)