Showing results for 
Search instead for 
Did you mean: 

Error when issuing the docker run command

I've been trying to set up the SAP HANA Express container on both CentOS 7.5 & Fedora 28 and in the end constantly keep on bumping into the following docker error:

docker: Error response from daemon: OCI runtime create failed: container_linux.go:344: starting container process caused "process_linux.go:424: container init caused "write sysctl key kernel.shmmni: write /proc/sys/kernel/shmmni: invalid argument"": unknown.
ERRO[0011] error waiting for container: context canceled

I have ran it on EC2 instances for both CentOS & Fedora and on the same type of instances on VM on my QNAP NAS.

Followed the tutorial over here:

It seems to be a docker related issue but I have no clue on how to get around this.

Thanks in advance.

For the record, the issued docker command is:

sudo docker run -p 39013:39013 -p 39015:39015 -p 39041-39045:39041-39045 -p 1128-1129:1128-1129 -p 59013-59014:59013-59014  -p 39030-39033:39030-39033 -p 51000-51060:51000-51060  -p 53075:53075 \
-h hxehost \
-v /data/hana:/hana/mounts \
--ulimit nofile=1048576:1048576 \
--sysctl kernel.shmmax=1073741824 \
--sysctl net.ipv4.ip_local_port_range='60000 65535' \
--sysctl kernel.shmmni=524288 \
--sysctl kernel.shmall=8388608 \
--name hana_express_edition \
store/saplabs/hanaexpressxsa: \
--agree-to-sap-license \
--passwords-url file:///hana/mounts/hxeadm.json

0 Kudos

Gonna give that a spin & thanks for the pointers.

I will keep you posted.

Active Contributor
0 Kudos

I don't know what the issue is with your docker installation but HANA express IS tested on Fedora and CentOS. I will try to get someone help with this.

Active Participant
0 Kudos

Hi Marc Huijbregts,

Did you solve this error? I have the same problem with Opensuse tumbleweed.

Thank you very much.

0 Kudos

Hi Marc Huijbregts/ Xavier Covis,

I am getting the same error. Could you please share the fix for this?


Accepted Solutions (1)

Accepted Solutions (1)

I was able to get the container to start by changing the shmmni value to that of the host, so in my case this happened to be 4096. Seems to work for running on my laptop for testing.
--sysctl kernel.shmmni=4096

I got this value from the file "/proc/sys/kernel/shmmni" referenced in the error.

0 Kudos

thanks Nicolas, works for me

0 Kudos

Thx a lot !
Works for me as well !

0 Kudos

Thanks works now

0 Kudos


Answers (0)