cancel
Showing results for 
Search instead for 
Did you mean: 

Error: "Invalid WSDL or WSDL not found, ..."

Former Member
0 Kudos

Dear all,

I installed both JAVA and ABAP stack (Sneak preview 6.40 SP15) on one box.

In the NSP I created a Web Service via SE37 using an existing RFC function module of my own. Then I released my Web Service for SOAP Runtime via WSCONFIG.

Next I checked the WSDL document and run a test via WSADMIN. On the right side I can see all retrieved data in a tree. Congratulation!

Problem 1)

Next I created a Web Dynpro Project in the NW DevStudio that uses my Web Service:

- the model using my WSDL from above and

- context and model binding

- a view showing a table and a pushbutton .

When I push my button I get an error message: Internal Server Error 500 ...

What went wrong?

Problem 2)

I deleted the Project in the NW DevStudio and started again. When I try to create a new Web Service Model (Import Web Service Model) I can not continue, because every time I provide the URL of the WSDL document

(that I successfully tested many times:

http://localhost:8000/sap/bc/srt/rfc/sap/ZGETMATWSD?sap-client=000&wsdl=1.1&mode=sap_wsdl )

the Model-Wizard show up an error message "Invalid WSDL or WSDL not found, ..."

Who can help???

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

Save WSDL localy (<i>Open WSDL URL in browser, View->Source, File->SaveAs</i>) and open local file in Model dialog again. It should work.

If you are using locally saved wsdl and still getting the error then that would mean your wsdl is not in the right format. Try using some validation tools.

Bala

Former Member
0 Kudos

Dear Bala,

thank you so much, it works.

Have a nice weekend, bye

Answers (0)