Showing results for 
Search instead for 
Did you mean: 

ERROR: program SAPSLDAPI_UNICODE not registered

Former Member
0 Kudos

I'm using the transaction SM59 and i make a test of the conection SAPSLDAPI and i get the following text:

EntrSist. Error de conexión

Det.error Error when opening an RFC connection

Det.error ERROR: program SAPSLDAPI_UNICODE not registered

Det.error LOCATION: SAP-Gateway on host / sapgw05

Det.error DETAIL: TP SAPSLDAPI_UNICODE not registered

Det.error COMPONENT: SAP-Gateway

Det.error COUNTER: 3705

Det.error MODULO: gwr3cpic.c

Det.error LINE: 1694

Det.error CÓD.RETORNO: 679

Det.error SUBRC: 0

Det.error RELEASE: 700

Det.error TMP.: Sat Aug 25 12:51:44 2007

Det.error VERSIÓN: 2

does anyone know what i have to do?

Thanks in advance...

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

looks like you have not created the SAPSLDAPI_UNICODE connection parametere on the J2EE side. We have to create these paramters for both SAPSLDAPI_UNICODEand LCRSAPRFC_UNICODE.

Is the connection test for LCRSAPRFC_unicode working ?

Perform the following steps to maintain the J2EE Connection Parameters for SAPSLDAPI:


1. Start your Visual Administrator either locally by choosing Start ®Programs or on your Integration Server by executing the file go from within the directory: .../usr/sap/

¡ User: SAPJSF (defined during installation)

¡ Password: ask system administrator

¡ Unicode: activate

5. Choose Set.


Former Member
0 Kudos

Thanks now i solved the problem..

Former Member
0 Kudos


I have the same error but with a 3'rd party Source System. Does it work also for External Source systems?

BR Henriette

Former Member
0 Kudos

Hi Henriette, i dont know if that solution works for a 3rd party, maybe you need to post your question as a new one.



Answers (1)

Answers (1)

Former Member
0 Kudos

Hi Erick,

Have you configure the SAPSLDAPI_UNICODE at the visual admin->JCO Provider?