cancel
Showing results for 
Search instead for 
Did you mean: 

ERROR: ORA-01031: insufficient privileges

Former Member
0 Kudos

hi all

i have installed portal on oracle 10.2.0.4

when i try to connect to database using connect as sysdba

ORA-01031: insufficient privileges

but when i try

conn sys/<password>@<sid> as sysdba

database is connecting

please help on this

regards

revanth

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi Arteria,

You're right, sqlplus / as sysdba connects as the sys user (so no OPS$ mechanism is invoked).

Can you double check some things?

1) Is your user in the dba group?

2) Is Oracle setup to recognize this group correctly?

3) Is your ORACLE_HOME variable value that same as value in this command?

conn sys/<password>@<sid> as sysdba

4) What is in your sqlnet.ora file?

Just some thoughts...

Former Member
0 Kudos

Go through the note: 400241

Former Member
0 Kudos

dear sunil,

i tried the note all steps are correct but still the problem occurs

i have checked the ops$ in oracle and the sidadm is member of the oradba and ora oper group also

and also i have checked the enviroinment variables also

please help on this

regards

revanth

Former Member
0 Kudos

Hi Reven,

Please check below things:

1 ) Login on SQL as

sidadm > sqlplus " /as sysdba "

Make Sure OPS$ users & SAPSR3 have role CONNECT, Resourse and SAPDBA.

If this is fine;Then Check

Shivam Mittal

Former Member
0 Kudos

hi shivam,

the steps u gave

Login on SQL as

sidadm > sqlplus " /as sysdba

is showing the error

as insufficient previlage

C:\Documents and Settings\eppadm> sqlplus " /as sysdba "

SQL*Plus: Release 10.2.0.4.0 - Production on Tue Dec 21 11:57:36 2010

Copyright (c) 1982, 2007, Oracle. All Rights Reserved.

ERROR:

ORA-01031: insufficient privileges

Enter user-name:

but i gave sys and password its not connecting

please suggest on this

regards

revanth

Former Member
0 Kudos

Hi,

Please check the S-note: Note 834917 and relevent sub notes in it for privilages problem.

Also check the thread

Regards,

Former Member
0 Kudos

Have you checked that the OPS$ users exist for your OS users sidadm and orasid?

You can check this via

select username from dba_users;

. The OPS$ users for both OS users should be listed in that output.

If you need to recreate them please check SAP note 50088 for further information.

Kind regards,

Former Member
0 Kudos

hi sven ,

i have checked the ops$ user they are available in dbauser list

regards

revanth

Former Member
0 Kudos

Did you check the privileges that should be assigned to the OPS$ users?

You should also check the Oracle profile parameters whether the parameter for REMOTE_OS_AUTHENT = TRUE is set correctly.

Apart from that perform R3trans -x as either sidadm or orasid and check the resulting log file trans.log.

Kind regards,