cancel
Showing results for 
Search instead for 
Did you mean: 

Error occurred in customized bex query

Former Member
0 Kudos
286

Hello guys,

I have trouble with a BEx Query in our BW landscape. Error is "Could not find any data to display. This might be due to the current selection of variable or filter values" I have created a query with a lot of key figures but I did not add any filter and variable. When I execute it in BEx (Excel) I did not get data and also I tried to execute it on web portal there is also same error.

Thanks,

Pankaj

Accepted Solutions (0)

Answers (5)

Answers (5)

former_member646117
Discoverer
0 Kudos

Hi Experts,

I am new here and to BW, I need your expertise to resolve this issue.

One of my user facing the same issue. I have checked everything which is discussed above but it did not resolve my issue. Pls help.

My Cube has reporting symbol. LISTCUBE shows all data. I did RSECADMIN, authorization check looks okay to me. the strange part is when I execute same report with my ID it works fine for me but the user is unable to execute the report and the error throws "Could not find any data to display. This might be due to the current selection of variable or filter values".

I am attaching RSECADMIN analysis report here.

I need your expert help on this.

Regards

Ruby

Former Member
0 Kudos

Hi All,

Issue has been solved, actually I was using different cube in query side that cube contains was same required fields but that was coming under obsolete info area (do not use)...

By the way Thanks to everyone for helping me

Regards,

Pankaj

RamanKorrapati
Active Contributor
0 Kudos

Hi,

please check at target level.

All loaded requests at your target have reporting symbol?

Cube/DSo-->manage-->request tab.

Is there any failed requests at target level?

As you said no filter/selections then just remove all key fig from column area.

add one key fig and save the query.

later try run it and see the result.

Thanks

Former Member
0 Kudos

Hi Raman,

Yes that request is available for reporting see this screen shot. and also I have removed all key fig from column area and added one key fig and saved the query but still I'm getting same error.

Thanks,

Pankaj

RamanKorrapati
Active Contributor
0 Kudos

Hi,

Can you check data at cube level.

Cube-->right click-->display data and see the data.

in above screen shot,a re you able to see any count under added coulumn? (records >0)

Above loaded request is full load or delta load?

Thanks

Former Member
0 Kudos

Hi,

36 rec added in target and its delta because its ISU's datasource that data wont come through setup table in source side I run this EBW_DQ_SS then rec populated in delta queue

Thanks,

Pankaj

RamanKorrapati
Active Contributor
0 Kudos

that's fine. Can you try to see the data at cube level. Cube-->display data--> see the cube data.

Later check data thru Tx - LISTCUBE.

if it displays then something wrong at reporting level.

Can you try to regenerate your report thru Tx - RSRT and see.

if not solved then try to create a one basic report on your cube and see.

Former Member
0 Kudos

Hi Raman,

I have checked through LISTCUBE. and also executed in RSRT  see this file

Thanks,

Pankaj

RamanKorrapati
Active Contributor
0 Kudos

Can you create one basic report on your cube and see.

Just use one obejct at respective areas.

like one info char object in Rows(0BPARTNER), one key fig in column.

save and run report.

sriramvijay_ravidoss
Contributor
0 Kudos

Hi Pankaj,

In the columns, there is no Key figure. Currently it looks like there are charactristics in both rows and columns.

Please drag and drop any valid key figure in columns and check.

-Sriram

Former Member
0 Kudos

Hi Sriram,

In column there are key fig but data is not able display.

Thanks,

Pankaj

former_member202257
Contributor
0 Kudos

Hello,

It is not exactly an error but rather the filter values are such that there is no data to display. can you attach a screenshot of the Filter tab in the query designer? It will help ascertain the cause.

Former Member
0 Kudos

Hi,

see this filter tab does not contain any field

Thanks,

Pankaj