Showing results for 
Search instead for 
Did you mean: 

Error : No receiver could be determined "NO_RECEIVER_CASE_ASYNC"

Active Participant
0 Kudos

Dear friends

I am trying to send file in my unix server using ABAP Proxy to File scenario. I am receiving this error No receiver could be determined " NO_RECEIVER_CASE_ASYNC" in sxmb_moni.

What I am doing is :

In IR I have this objects developed and they are activated.

Data type : dt_acc_create_st

element dt_acc_create_st ( complex type )

attribute: param : xsd:string type.

(ii) Message type : MT_ACCS_UNI

data type used: dt_acc_create_st

(iii) Service Interface :SI_ACCOUNT_CREAT

attributes: Outbound

interface pattern : stateless

Operational Pattern : Normal Operation

Mode : Asyncronous.

message type used: MT_ACCS_UNI


(iv) In SE80

Function module calls the abap proxy and triggers it with this code:

data: proxy_create_acc type ref to ZCO_SI_ACCOUNT_CREAT,
                lv_param_l type ZMT_ACCS_UNI,
                im_account type ZDT_ACC_CREATE_ST.

                im_account-param = im_param.
                lv_param_l-MT_ACCS_UNI = im_account.

               create object proxy_create_acc.
               CALL METHOD proxy_create_acc->si_account_creat
                               output = lv_param_l.
               commit work.

               CATCH cx_ai_system_fault.

In Integration Directory.

(v) Party : P_Unixsys

(vi) Communication component: BC_UNIXSYS_ACC_CREATE

Receivers : Inbout Interface <none>

communication channle : CC_UNIXSYS_ACC_CREATE

senders : Outbout Interface: si_account_creat

communication channle : <none>

(vii) Communication Channel : CC_UNIXSYS_ACC_CREATE

Adapter type: File

(X) Receiver.

Transport protocol: FTP

Message protocol: File

Adapter Engine: Central Adapter Engine

Target Directory: /var/EDPD/scripts

File name scheme: xi_output.dat

FTP Connection parameter:

Server: myFTPServer

port: 21

data connection: active

connection security: none

connection mode: paremently

transfer mode: text.

(iix) Reciever aggrement : <none> since I am using abap proxy to File I didnt use senders. do i need senders,, and mapping as well?

please reply me i have wittent everything what i m doing here. please reply me. your any help will be appreciated.



Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos


This error completly signifies that the message could not able to determine the receiver in the receiver determination step(plz chk the condtion if u r mentioning any under Receiver Determination)..

I guess (and as u mentioned) u have properly created

1) Receiver determination , 2) Interface determination, 3) Receiver agreement and 4) File receiver CC.



Active Participant
0 Kudos

I have all the objects !

I try to test it in test configuration from receiver determination...

it gives me this error

" Runtime exception occurred during application mapping com/sap/xi/tf/_MM_UNIX_ACCOUNT_CREATE_; is not allowed in prolog. "

may be this is the reason why its not going. please put some light on it..



this error is no more... it was due to incorrect id configuration that I have solved and it is fine. I can see success message in test configuration. but still i have the same error "NO_RECEIVER_CASE_ASYNC" in sxmb_moni :,(

Edited by: Naim Khan S Babi on Apr 24, 2011 2:42 PM

Active Participant
0 Kudos


are you trying to repush the same message which failed in IE. if yes test the end to end again.

orelse check the Receiver Interface in IR whether its Sysn or Async.



Active Participant
0 Kudos

my message is asyncronise

Answers (5)

Answers (5)

0 Kudos

Hello experts, I have the same problem, but my scenario is proxy to JDBC, and did the steps mentioned above but just keep mind without fortune, have any other ideas that might cause this error, because objects are developed IB and as of any moment was that this error showed up ......

Thank you for your attention

0 Kudos


Try the cache refresh with the link:


And proceed to:

- In Integration Repository/Directory go to menu Environment ->

Clear SLD Data Cache

- In R/3 go to transaction SXI_CACHE -> menu XI Runtime Cache -> Start

Complete Cache Refresh


Caio Cagnani

0 Kudos


It seems to like problem with your target directory.

Please specify your Target Directory as \var\EDPD\scripts instead of /var/EDPD/scripts.

Please see the below link, it might be useful to you.





Former Member
0 Kudos


Can you please ensure that your Receiver File Channel is ACTIVE and STARTed ?



0 Kudos

Hi Naim,

It seems to like problem with your message mapping. Once again cross check with your message mapping. And test the message mapping whether it will perfectly working or not.

Did you try to test your configuraton in integration directory -> tools -> test configuration?

And, if still problem persist, please refresh CPA Cache Refresh by using the following URL:

URL: http://<hostname>:<port>/CPACache/refresh?mode=full

Hope this helps to you.



Active Participant
0 Kudos

I have tested in test configuration and no error there... well yesterday it was there due to mapping but I fix everything in IR and ID ... In Test configuration I have successful message.. no errors.

I dont have authorisation for refreshing the cache... well I will ask my PI admin to do it.

except this there wont be any other reason right ?

I am thinking May be I am doing anonymous login in FTP server ..and it might be not allowing me to go in to perticular directory.

not sure.. this is just a speculation I am building in my mind.

Former Member
0 Kudos


This error usually comes when the reciever could not be determined in the pipeline steps.

Please recheck the Receiver Determination step in ID..esp the sender interface. Let us know if you still face this error..