cancel
Showing results for 
Search instead for 
Did you mean: 

error message on pool

Former Member
0 Kudos

got message from console like:

The 2K memory pool of named cache my index cache (cache id 4, cachelet id 1) is configured too small for current demands (state 2).

Transaction progress may cease or response time may increase.

here is the info for the pool:

1> sp_poolconfig "my index cache"

2> go

Cache Name                     Status    Type     Config Value Run Value

------------------------------ --------- -------- ------------ ------------

my index cache                 Active    Mixed      1074.22 Mb   1074.22 Mb

(1 row affected)

                                                   ------------ ------------

                                            Total    1074.22 Mb   1074.22 Mb

==========================================================================

Cache: my index cache,   Status: Active,   Type: Mixed

      Config Size: 1074.22 Mb,   Run Size: 1074.22 Mb

      Config Replacement: relaxed LRU,   Run Replacement: relaxed LRU

      Config Partition:            4,   Run Partition:            4

IO Size  Wash Size     Config Size  Run Size     APF Percent

-------- ------------- ------------ ------------ -----------

     2 Kb         64 Kb      0.00 Mb    239.27 Mb     10

    16 Kb      61440 Kb    834.96 Mb    834.95 Mb     10

(return status = 0)

Not sure why. This is restore a production mydb on dev server. No this information on production.

Is it because of info in master and mydb not consistently?

Former Member
0 Kudos

Thanks. but I did not change anything on pool or this index cache. What I did is create a new data cache, then bind some indexes to this new cache. those indexes maybe bound to this index cache. Should I unbind those indexes firstly, the bind them to new cache?

Mark_A_Parsons
Contributor
0 Kudos

Well, someone tried setting the 2KB pool to 0MB (which matches with one of your other threads regarding eliminating a cache/pool):

====================

IO Size  Wash Size     Config Size  Run Size     APF Percent

-------- ------------- ------------ ------------ -----------

     2 Kb         64 Kb      0.00 Mb    239.27 Mb     10     <<<=== changed from 239.27 Mb to 0.00 Mb

    16 Kb      61440 Kb    834.96 Mb    834.95 Mb     10

====================

While the attempt to change the 'Run Size' of the pool will take place during the next reboot, it appears the 'Wash Size' was automatically reduced to 64 Kb (or someone explicitly defined it to this tiny value).

As Brett's mentioned, the small wash size (64 Kb) is likely causing the error message.

And since the dataserver is complaining about the 2KB being too small this would tend to indicate the dataserver still needs to use the 2KB pool, which would tend to indicate you cannot eliminate the 2KB pool.

To get rid of the error message I'd recommend you add space back to the 2KB pool (eg, try something like 10MB), and make sure this resets the wash size to something a bit larger than 64Kb.

If you still get the error message then you may need to bump up the size of the 2KB pool a bit more and/or increase the size of the wash.

Former Member
0 Kudos

Thank you. Interesting thing is: maybe someone changed it before. I also get message from errorlog yesterday:

00:00000:00055:2014/05/02 21:06:54.57 server  The 16K memory pool of named cache my index cache (cache id 3, cachelet id 3) is configured too small for current demands (state 2). Transaction progress may cease or response time may increase.

So I guess I need to reset wash size with following calculation:

run size(2k) X APF Percent = wash size

so for 2K pool,

wash size = 239.27*1204*2*10% = 49002k

16k pool:

wash size = 834.96*1204*2*10% = 171000k

then should the problem fixed? Or I only need to change the config size, then ASE will calc wash size?

Another question: if someone try to change 2k pool wash size too small(for example this case 64k) and Config Size to 0, but never reboot ASE after for this change, If I reboot ASE, this 2k pool will removed?

Accepted Solutions (0)

Answers (1)

Answers (1)

former_member188958
Active Contributor
0 Kudos

The wash size for the 2k pool is very small.  This message gets output when ASE needs a clean buffer to read data into but none are available.  Increasing the size of the wash region causes more buffers to be flushed earlier, improving the chances that ASE will find a clean one (you want ASE to always be able to find a clean one).

The "config size" of 0 suggests that you are trying to drop this pool, however.  So I think you either want to finish dropping it or reconfigure it for memory and increase the wash region size.

-

bret