cancel
Showing results for 
Search instead for 
Did you mean: 

Error inthe sender RFC

Former Member
0 Kudos
107

BAPI -XI- XML

When i am sending BAPI from sap to xi i getting following error .

"call to messaging system failed: com.sap.aii.af.ra.ms.api.DeliveryException

But the bapi as posted in to xi.

when i want check in sxmb_moni there no message for selection

but it is populated in reciver system.

so plz help me regarding this

upendra

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

hi,

When u check with sxmb_moni there change the date in the selection field and then click on execute then u can see messages.

Even check it runtime workbench ie message monitoing in that also in the selection screen change the date or time to the back and then click on start

now u can see the messages.

Even if there are no messages or if u get any errors like system error then contact u r basis administrator for updating or problem with ur database.

Reward points is useful,

Regards,

Srinivas.D

Former Member
0 Kudos

Hi

srinivas

when i checked in message monitering

integration Engine status was : system error

so wt is my mistake

if posted some wrong lookup values at that time i am able to see the my messages in sxmb_moni (the falg status was in system error)

only if i gvien currect vaules i am unble to see status in moni

thanks for ur kind information

upendra

bhavesh_kantilal
Active Contributor
0 Kudos

>

> if posted some wrong lookup values at that time i am

> able to see the my messages in sxmb_moni (the falg

> status was in system error)

> only if i gvien currect vaules i am unble to see

> status in moni

Which implies your scenario works fine.

The reason you are not able to see a successful message in MONI is becuase by default synch messages are not logged in XI . To see this , do the following,

T code : SXMB_ADM --> Integration Engine configuration --> Specific configuration --> Add parameter LOGGING_SYNC with value 1 of category RUNTIME.

Regards

Bhavesh

Former Member
0 Kudos

Hi

Bhavesh

Thanks for ur solution .

now i am able to see my messages in moni but status was LOG version

plz help me

thanks

upendra

bhavesh_kantilal
Active Contributor
0 Kudos

Not sure i understood what the problem here is

Can you please explain in detail.

Regards

Bhavesh

Former Member
0 Kudos

Hi

Bhavesh

i configured in sxmb_adm (that as u given soultion)

runtime: syncr_logging value 1

after done this i am able to see my messages in sxmb_moni but

the problem is flag status was log version(in sxmb_moni)

so what is the mistake

thanks

upendra

Answers (3)

Answers (3)

Former Member
0 Kudos

I think you have to enable the Remote Function Call in the RFC function module using BAPI's. Just check whether you have enable the functionality or not,

Furthermore, You have to check in the Integration Monitoring

(Runtime Workbench) RWB adaptor monitoring whether the message have been successfully transmitted or not.

Also, Provide the Credential for the R/3 system like server name, Username , Logon details.

If everything is not going according to the way you want , I Strongly recommend you to Start over again.

Thanks

Shiv

bhavesh_kantilal
Active Contributor
0 Kudos

Upendra,

What is the sender business system that you have used?

Is this a WebASABAP Business System?

Also, did you turn of Synch Logging ofr messages in MONi?

regards

Bhavesh

Former Member
0 Kudos

HI

Bhavesh

FOR ur reference

if posted some wrong lookup values at that time i am

> able to see the my messages in sxmb_moni (the falg

> status was in system error)

> only if i gvien currect vaules i am unble to see

> status in moni

Which implies your scenario works fine.

The reason you are not able to see a successful message in MONI is becuase by default synch messages are not logged in XI . To see this , do the following,

T code : SXMB_ADM --> Integration Engine configuration --> Specific configuration --> Add parameter LOGGING_SYNC with value 1 of category RUNTIME.

i configured in sxmb_adm (that as u given soultion)

catagery: runtime:

parameter logging_sync

value :1

after done this i am able to see my messages in sxmb_moni but

the problem is flag status was "log version" (in sxmb_moni)

so what is the mistake

so plz help me

thanks

upendra

bhavesh_kantilal
Active Contributor
0 Kudos

><i>the problem is flag status was "log version" (in sxmb_moni)</i>

Not sure I understand what you mean here. Please provide more details and try to explain things better so that you get appropriate responses!

Regards

Bhavesh

Former Member
0 Kudos

Are you just restarting the messages from SXMB_MONI or sending a new one?

Log Version matches the various versions of the message.So if you took the message ID of the failed message and look it up in table SXMSPVERS you will see multiple versions of your message.

For a clean start - cancel your failed message in SXMB_MONI and start again or run reports described in note 728151 and related notes for more info - I think your status is 001 (too many versions)

sincerely,

--NM

Former Member
0 Kudos

Hi

Bhavesh

BAPI TO XML

(RFC TO FILE)

in my sender communication channel (SENDER RFC)monitering i am getting following error

plz check this

Error: 2007-07-10 04:28:49 UTC: Message processed for interface Sender channel 'CC_RFC_SND_DEVWR0004357' for party '', service 'GLB_GT_A_GD2DVRC152_DV_R3P' (internal name 'RfcServer[CC_RFC_SND_DEVWR0004357]')

Server data: {jco.server.gwhost=gissap.nestle.com, jco.server.progid=ZTEST, jco.server.gwserv=sapgw00, jco.server.unicode=1}

Repository data: {jco.client.lang=en, jco.client.snc_mode=0, jco.client.client=152, jco.client.passwd=******, jco.webas.ignore_jdsr_error=1, jco.client.user=XPCD_UPENDRA, jco.client.sysnr=00, jco.client.ashost=ddadb319}

Current pool size: 1, maximum pool size : 50

Channel History

- Error: 2007-07-10 04:38:38 UTC: Message processed for interface /GLB/RGT_STOCK_ENQUIRY_OUT: com.sap.aii.af.mp.module.ModuleException: call to messaging system failed: com.sap.aii.af.ra.ms.api.DeliveryException: XIServer:NO_MAPPINGPROGRAM_FOUND: caused by: com.sap.aii.af.ra.ms.api.DeliveryException: XIServer:NO_MAPPINGPROGRAM_FOUND/GLB/RGT_STOCK_ENQUIRY_OUT: com.sap.aii.af.mp.module.ModuleException: call to messaging system failed: com.sap.aii.af.ra.ms.api.DeliveryException: Application:EXCEPTION_DURING_EXECUTE: caused by: com.sap.aii.af.ra.ms.api.DeliveryException: Application:EXCEPTION_DURING_EXECUTE:

But still the messages are currectly populating in my reciver system

problems are:

Q: status of sxmb_moni :log version

Q:when i am posting bapi useing se37 from sap system to xi the following error i am getting

"call to messaging system failed: com.sap.aii.af.ra.ms.api.DeliveryException:"

but still it is posted in to xi currectly

so plz help regarding this

thanks for ur help

upendra.v

prateek
Active Contributor
0 Kudos

Refer to SAP Note 730870.

Also check out for the exact cause in RWB -> Message Monitoring

Regards,

Prateek

Former Member
0 Kudos

Hi

prateek

when i checked in message monitering

integration Engine status was : system error

so wt is my mistake

thanks for ur kind information

upendra

prateek
Active Contributor
0 Kudos

Click on the message and view details. It will display the Audit log and the description of error.

Also check for the Program ID in XI and R3 and make sure it is registered on J2EE.

Regards,

Prateek

bhavesh_kantilal
Active Contributor
0 Kudos

> Also check for the Program ID in XI and R3 and make

> sure it is registered on J2EE.

There needs to be no registration done on the j2ee engine for a sender RFC for the program id's.

Regards

Bhavesh