cancel
Showing results for 
Search instead for 
Did you mean: 

Error in Assistance class.

Former Member
0 Kudos

Hi experts,

I am getting an error in assistance class, below is the error :

" Web Dynpro Comp. / Intf. ZWD_TEST,Web Dynpro View V_TEST

Attribute WD_ASSIST

The type "ZASSIST_DISP" is unknown, but there is a type with the

similar name "IG_ZWD_TEST" . . . . . "

where :

ZASSIST_DISP is the assistance class,

ZWD_TEST is the component,

V_TEST is the view.

But when i activate it anyway , it works fine.

Help me in this error.

Thanks

Aisurya

Accepted Solutions (0)

Answers (3)

Answers (3)

Aisurya
Participant
0 Kudos

partially answered

Former Member
0 Kudos

Make sure that the super class of your assistance class is CL_WD_COMPONENT_ASSISTANCE.

Rohit

saravanan_narayanan
Active Contributor
0 Kudos

Hello Aisurya,

Did you have activate the ZASSIST_DISP class? If not first activate the class. then activate the entire webdynpro component in display mode.

BR, Saravanan

Aisurya
Participant
0 Kudos

yes it is activated, and all the methods in it working fine..

The component is getting activated , if we activates "Activate anyway".

Its working fine,but there is error in code inspector as well as in the view.

Thanks Aisurya

saravanan_narayanan
Active Contributor
0 Kudos

Hello Aisurya,

this is strange. try the following. go to display mode of the webdynpro component or load the component in display mode and try to activate the entire component from the left navigation panel.

BR, Saravanan

former_member450736
Active Participant
0 Kudos

Hi,

Make sure that component is error free, if you perform syntax check it might be giving out some errors, correct those errors and then check it, 'activate anyway' does not always help.

Former Member
0 Kudos

Hi,

I believe this is due to you using an interface as an assistance class. This will normally generate the error "the type ZIF_CLASSNAME is unknown, but there is a type with the similar name IG_ZIF_CLASSNAME..."

Make sure your assistance class is a proper class, and not an interface, and your problem should be solved.

Regards,

Trond