cancel
Showing results for 
Search instead for 
Did you mean: 

Error in Activation of Transformation

Former Member
0 Kudos

Hi,

I was trying to activate my transformation, but there was an error during activation which I couldn't understand. I manage to track down the problem area. Here's my case:

I'm converting a Timestamp Source field to 2 Target fields, Time and Day. So I implemented routine to derive at the values with the following code.

lv_tstamp = source_fields-/BIC/ZCRM_ICTS.

CONVERT TIME STAMP lv_tstamp

TIME ZONE 'UTC ' INTO DATE lv_day TIME lv_time.

result = lv_day (or lv_time).

The transformation activates successfully if the routine is implemented on 1 target field, but when I implement the routine for both target fields, it results in error during activation. No error occur when I check on the transformation.

Anyone had an idea why this is happening?

Thanks in advance.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

If I remember correctly, 905624 fixed the problem.

Good luck

Ioan

Former Member
0 Kudos

Hi all,

Thanks for the help. I have check that all the latest system support package has been applied, but the problem still exist. It doesn't matter for now because I switch to using expert routine which works just fine.

Thanks,

CK

Answers (2)

Answers (2)

Former Member
0 Kudos

Hello CK

If I remember correctly, the OSS note 905624 is in SP7, which is not available for install yet. Therefore, you will need to apply the note, for example, by using the transaction SNOTE

Hope this helps - expert routine is great, but lots of code - straight mapping is easier!!!

Ioan

former_member192700
Active Contributor
0 Kudos

That's correct.

Cheers

SAP NetWeaver 2004s Ramp-Up BI Back Office Team

Former Member
0 Kudos

Hi

What is the specific error message you get when you try to activate the transformation? If I remember correctly, I had a similar problem (fails to activate but no error when checking) and I got that fixed w/ an OSS note

Good luck

Ioan

Former Member
0 Kudos

Hi loan,

This was the error message:

<i>

Error while activating transformation

Message no. RSTRAN510</i>

Nothing else was specified, is this similar to your previous problem? do you know the OSS note to fix this error? Really appreciate if you could help me with this.

Thanks.

former_member192700
Active Contributor
0 Kudos

Hi Ioan,

please check OSS notes

  • 918894 ASSERT: InfoCube with navigational attributesas source

  • 909741 Non-cumulative cube: Transformation cannot be saved

  • 905624 Transformation cannot be activated

Cheers

SAP NetWeaver 2004s Ramp-Up BI Back Office