cancel
Showing results for 
Search instead for 
Did you mean: 

ERROR HTTP 404

Former Member
0 Kudos
257

Hi, guys have this error.

Audit Log for Message: 3c8fc610-bc93-11d9-b253-080020f7cc23

Time Stamp Status Thread ID Sequence No. Description

2005-05-04 11:54:14 Success RfcServer[RFC_Sender]1 1115207654641 RFC adapter received sRFC for STFC_CONNECTION from CCD/210. Attempting to send message synchronously

2005-05-04 11:54:14 Success SAPEngine_Application_Thread[impl:3]_24 1115207654652 Application attempting to send an XI message synchronously using connection AFW.

2005-05-04 11:54:14 Success SAPEngine_Application_Thread[impl:3]_24 1115207654654 Trying to put the message into the call queue.

2005-05-04 11:54:14 Success SAPEngine_Application_Thread[impl:3]_24 1115207654656 Message successfully put into the queue.

2005-05-04 11:54:14 Success SAPEngine_System_Thread[impl:5]_45 1115207654657 The message was successfully retrieved from the call queue.

2005-05-04 11:54:14 Success SAPEngine_System_Thread[impl:5]_45 1115207654658 The message status set to DLNG.

2005-05-04 11:54:14 Error SAPEngine_System_Thread[impl:5]_45 1115207654684 Returning synchronous error notification to calling application: Received HTTP response code 404..

2005-05-04 11:54:14 Error SAPEngine_Application_Thread[impl:3]_24 1115207654684 Transmitting the message using connection http://ssbra35:51400/sap/xi/engine?type=entry failed, due to: Received HTTP response code 404..

2005-05-04 11:54:14 Error SAPEngine_Application_Thread[impl:3]_24 1115207654687 The message status set to FAIL.

2005-05-04 11:54:14 Error SAPEngine_Application_Thread[impl:3]_24 1115207654689 Returning to application. Exception: Received HTTP response code 404.

We dont know what's happening.

The scenario is R/3 > XI using RFC.

Please help-me.

regards,

Mattos.

Accepted Solutions (0)

Answers (1)

Answers (1)

MichalKrawczyk
Active Contributor
0 Kudos

Hi Gerardo,

other messages working?

you can check rfc dest (SM59):

INTEGRATION_DIRECTORY_HMI

if the path and port are correct

do a test and check if you got http 500

Regards,

michal

Former Member
0 Kudos

Hei Michal, thanks for help!

So, I check the your sugestion and get the message HTTP 500

I following the message error.

HTTP NAME HTTP VALUE

response_line HTTP/1.1 500 Internal Server Error

server_protocol HTTP/1.1

status_code 500

status_reason Internal Server Error

connection close

set-cookie JSESSIONID=(ssbra35_XID_14)ID145634550DB682732612750138249End; Version=1; Path=/

set-cookie saplb_*=(ssbra35_XID_14)145634550; Version=1; Path=/

server SAP J2EE Engine/6.40

pragma no-cache

content-type text/html;charset=ISO-8859-1

content-length 3338

date Wed, 04 May 2005 17:12:26 GMT

HTTP BODY

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">

<html>

<head>

<title>Error Report</title>

<style>

td font-family : Arial,

Tahoma, Helvetica, sans-serif; font-size : 14px;

A:link color : #0059

AA;

A:visited color : #999999;

A:active color : #999999;

</style

>

</head>

<body marginwidth="0" marginheight="0" leftmargin="0" topmar

gin="0" rightmargin="0">

<table width="100%" cellspacing="0" cellpaddin

g="0" border="0" align="left" height="75">

<tr bgcolor="#FFFFFF">

<td align="left" colspan="2" height="48"><font face="Arial, Verdana, Hel

vetica" size="4" color="#666666"><b>&nbsp;&nbsp;500 &nbsp Internal Serve

r Error</b></font></td>

</tr>

<tr bgcolor="#3F73A3">

<td height="

23" width="84"><img width=1 height=1 border=0 alt=""></td>

<td heig

ht="23"><img width=1 height=1 border=0 alt=""></td>

<td align="righ

t" height="23"><font face="Arial, Verdana, Helvetica" size="2" color="#F

FFFFF"><b>SAP J2EE Engine/6.40&nbsp;</b></font></td>

</tr>

<tr bgcolor

="#9DCDFD">

<td height="4" colspan="3"><img width=1 height=1 border

=0 alt=""></td>

</tr>

</table>

<br><br><br><br><br><br>

<p><font fac

e="Arial, Verdana, Helvetica" size="3" color="#000000"><b>&nbsp;&nbsp;Ap

plication error occurred during the request procession.</b></font></p>

<p><font face="Arial, Verdana, Helvetica" size="2" color="#000000"><tabl

e><tr><td valign="top"><b>&nbsp;Details:</b></td><td valign="top"><PRE><

pre>javax.servlet.ServletException: REQID not found

at com.sap.aii.ibdi

r.web.abapcache.CacheRefreshSession.getInstance&#40;CacheRefreshSession.

java:50&#41;

at com.sap.aii.ibdir.web.abapcache.CacheRefreshServlet.doG

et&#40;CacheRefreshServlet.java:45&#41;

at javax.servlet.http.HttpServl

et.service&#40;HttpServlet.java:740&#41;

at javax.servlet.http.HttpServ

let.service&#40;HttpServlet.java:853&#41;

at com.sap.engine.services.se

rvlets_jsp.server.HttpHandlerImpl.runServlet&#40;HttpHandlerImpl.java:38

5&#41;

at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.h

andleRequest&#40;HttpHandlerImpl.java:263&#41;

at com.sap.engine.servic

es.httpserver.server.RequestAnalizer.startServlet&#40;RequestAnalizer.ja

va:340&#41;

at com.sap.engine.services.httpserver.server.RequestAnalize

r.startServlet&#40;RequestAnalizer.java:318&#41;

at com.sap.engine.serv

ices.httpserver.server.RequestAnalizer.invokeWebContainer&#40;RequestAna

lizer.java:821&#41;

at com.sap.engine.services.httpserver.server.Reques

tAnalizer.handle&#40;RequestAnalizer.java:239&#41;

at com.sap.engine.se

rvices.httpserver.server.Client.handle&#40;Client.java:92&#41;

at com.s

ap.engine.services.httpserver.server.Processor.request&#40;Processor.jav

a:147&#41;

at com.sap.engine.core.service630.context.cluster.session.Ap

plicationSessionMessageListener.process&#40;ApplicationSessionMessageLis

tener.java:37&#41;

at com.sap.engine.core.cluster.impl6.session.Unorder

So, We setting the parameters for Tager HOST = <Server XI> PORT = 51400 and PATH PREFIX = /dir/cache refresh

this correct right?

Thanks for help!

Regards,

Mattos.

MichalKrawczyk
Active Contributor
0 Kudos

and if you give path prefix:

/dir/hmi_cache_refresh_service/ext

what have you got?

still not working?

Regards,

michal

Former Member
0 Kudos

Michal, we change the path prefix to <b>/dir/hmi_cache_refresh_service/ext</b> and now we have the message

HEADER NAME HEADER VALUE

response_line HTTP/1.1 200 OK

server_protocol HTTP/1.1

status_code 200

status_reason OK

connection close

set-cookie JSESSIONID=(ssbra35_XID_14)ID145634550DB692621668961666717End; Version=1; Path=/

set-cookie saplb_*=(ssbra35_XID_14)145634550; Version=1; Path=/

server SAP J2EE Engine/6.40

content-type text/html

date Wed, 04 May 2005 19:57:15 GMT

HTTP BODY

<html>

<head><title>HMI Servlet - worker external client</title></head>

<body><p>

Worker "external client" of servlet "HMI servlet #1" is reacha

ble!<p>

<p></body></html>

Time (ms) 14.313

Michal, and now??? its working?

What do you think?

Regards,

Mattos.

MichalKrawczyk
Active Contributor
0 Kudos

have you tried your scenario "R/3 > XI using RFC" ?

do you still see those error messages?

(Exception: Received HTTP response code 404.)

regards,

michal

Message was edited by: Michal Krawczyk

Former Member
0 Kudos

yes my scenario is R/3 > XI using RFC.

The errors we posted in initial topic ref. HTTP 404.

MichalKrawczyk
Active Contributor
0 Kudos

yes, but have you tried your scenario

after the changes in rfc dest? (with http 200 ok)?

you still have the same error?

Regards,

michal

Former Member
0 Kudos

Michal, look this error please.

Sender Adapter v1014 for Party 'TESTE_TRANSF_R3', Service 'TESTE_TRANSF_R3_CCS':

Configured at 19:33:47 2005-04-26

Last message processing started 19:33:48 2005-04-26, Error: Module Exception 'com.sap.aii.af.mp.module.ModuleException: senderChannel 'e704d1a8b751306babe206cd546b7317': Catching exception calling messaging system' found, cause: com.sap.aii.af.ra.ms.api.DeliveryException: Received HTTP response code 404.

last retry interval started 19:33:48 2005-04-26

length 900,000 secs

any ideia for fix the error?

Thanks,

Mattos.

Former Member
0 Kudos

Hey Guys, help-me!!!!

MichalKrawczyk
Active Contributor
0 Kudos

is this an error from the adapter monitoring?

if so, maybe you can check the all logs for this adapter in the visual admin -> log viewer

just to make sure you can also take a look

in the SLD - business system for the XI

can you check the Pipeline URL

it should be something like:

http://server:port(http - like 8010)/sap/xi/engine?type=entry

regards,

michal

MichalKrawczyk
Active Contributor
0 Kudos

BTW

you can find your

http port with TCODE SMICM (goto ->services)

regards,

michal