cancel
Showing results for 
Search instead for 
Did you mean: 

Error FWM 01006 when creating dashboard using QAAWS on Web Intelligence Report

Former Member
0 Kudos

Hi everyone,

I created a dashboard with SAP BO Dashboard 4.0 using QAAWS based on Web Intelligence Reports. When I connect to the BO plateform, to execute the dashboard, many times from many machines I get the Error:

Unable to connect to service WebiPlugin.WebiSession from server PRD:6400 via CMS osca:iiop://PRD:6400;SI_SESSIONID=13882JW72z354vzeZWmQs2zfjxg3,SI_SERVER_LOGON_SESSION=1 (FWM 01006)

When I take a look at the servers in the BI plateForm I find that one of Web Intelligence services is overload ! and I have to restart it !

I guess that every time I execute the dashboard, it opens a new session that remains open!!

Plz help me how I can avoid this.

Thks,

Accepted Solutions (1)

Accepted Solutions (1)

vinay_mhaske
Contributor
0 Kudos

Hi,

You can refer following resolution mentioned in the SAP Knowledge Base Article “1778657 - Unable to connect to service WebiPlugin.WebiSession from server {...} via CMS {...} (FWM 01006) (Error: INF) error occurs when refreshing a Webi report in BI 4.0.”

Resolution:

Change the "Web Intelligence Process Settings" so that the first available server is used by following these steps:

  1. Login to Central Management Console (CMC).
  2. Click on Folders.
  3. Select the report that is to be refreshed.
  4. Click on Default Settings --> Web Intelligence Process Settings and select the "Use the first available server" option.
  5. Click "Save & Close".

Hope this helps!

Thank you.

Regards,

Vinay Mhaske

Former Member
0 Kudos

Hi Vinay, thank you for your response.

That's already done by default in the BO 4.0 SP04, but I still have the issue! when I execute the dashboard many times, one of the Web intelligence servers is overload and I have to restart it!!

Any suggestions would be helpful

Thank you in advance.

Former Member
0 Kudos

Hey Abdessamad,

Refer following SAP KBA :

1744668 - Dashboard error due to Webi Sessions Maxed

which says applying patch 1 on top of BI 4.0 SP04 resolves the issue.

Like I said earlier, it is a know issue which is now been fixed in patch 1.

Thanks,

Tejas

Former Member
0 Kudos

Hi Tejas,

Yes, you're right, I'm downloading it to fix this issue.

Thank you for your help.

Former Member
0 Kudos

Hi Tejas,

We have exactly the same problem. With teh same scenario  as the original Poster .We are on patch level BI 4.0 SP5. We raised the issue with SAP .We are still waiting to get fix from SAP.

We also experience this issue with our regular WEBI reports that are scheduled in launch pad .

Any help to get over this problem is highly appreciated.

regards

Kesava

Former Member
0 Kudos

Hi Kesava,

If you are facing the same error message, it means that on the Business Objects there are a lot of webi sessions that are opened.

if you are using BO Dashboard on Webi reports, when you open your dashboard many times, there are many session that are created and still being opend even if the dashboard is closed each time...

So check if any webi server gets down when you're facing the problem and try to restart it.

You can also increase the number of the session that can be created (pay intention to performance) on webi server and decrease the session cleanup interval

Hope it helps,

Abdess

Former Member
0 Kudos

Hi Abdess,

Thanks for your reply on Kesava. We both works together, while discussing yesterday we endup with a unanswered quetions.

1. Is there any method in Dashboards to close all the connections once received the data?

2. As you suggested, we verified and all the WEBI Processing services are running at the time of issue occurrence.

3. we have right now 6 WEBI Processing services and on each processing server we have 150 max connection limit. (is this is different you are suggesting increase session )?

Please help us to resolve the issue.

Thanks,

Srinivas

Former Member
0 Kudos

Hi Srinivas,

1- I don't think there is a method to close QAAWS connections on the Dashboard one the data are received!! and it's useful to close connections because on Dashboards we ofen have parameters like Years, Plant ...Etc. So if we close conections we have te connect again each time we want to actualize the dashboard data.

I don't know wich autentication method you're using to get data from QAAWS, if you explicitly give a user and password to QAAWS Inputs, so you'are creating a new session each time you are opening the dashboard.

But, you can get the InfoView logon token to avoid creation of new sessions and use the same session as the infoView, in this case, you just have to close the InfoView (by clicking on the log off button) to clear session.

2- In my case, while I was facing the problem the Web Intelligence Processing Server gets Red color on the health status

3- I increased the number of sessions to 100, but all depends on the number of users can open Dashboards basing on QAAWS in the same time.

Get into the habit of loging off the Launch pad/CMC by clicking the log off button

Let me know your BO version (Entreprise, Edge...) and how things are going with you.

Thanks

Abdess

Former Member
0 Kudos

Hi Srinivas,

I have just tested how we can use BO session in QAAWS connection on BO Edge Server SP05. So to use use the BO session to get data to Dashboard through QAAWS you have to not bind user and password fields on Xcelesius Data Manger. In that way when you open the Dashboard from CMC/BI launch pad, it uses the same session as the system. In that way you avoid creating of maultiple sessions.

But if you open the dashoard outside of the CMC/BI Launch pad, you'll be propted for credentials...

Get into the habit of loging off the Launch pad/CMC by clicking the log off button, so all opend session get closed

Hope it helps,

Abdess

Former Member
0 Kudos

Hi Tejas,

Currently we are at BI4.0 SP5 Patch 4, still getting same issue. Is there any issue with the patch..?

Thnaks,

Srinivas

Former Member
0 Kudos

Hi,

I am currently experiencing that issue... but i am kind of newbie with Dashboards and BO and I need your help please. Could anyone tell me how can I restart the servers? and How to increase the number of sessions?

Thanks!!

I really hope you can help me.

Former Member
0 Kudos

Check out 1753465. It states the same information as found in 1744668. It sates to use Patch 1 but it has this following advice:

The code correction is in the DSWSBobje Web Services Provider.  If you have deployed dswsbobje.war to a web application server other than the default one supplied with the SAP BusinessObjects Platform product, please ensure that you've re-deployed the dswsbobje.war to your web application server.

Hope that may help.

I have been looking at just re-starting the web application processing server. I created a probe that re-starts the web application processing server if the number of connections are to high. It works but it causes issues for regular webi users as they won't be able to refreash their reports in webi. They would have to sign out again..  Any other suggestions out there to get around this problem other than using the patch?

Former Member
0 Kudos

I tried the closeDocument as stated below and it worked for me. No more webi sessions staying open. More importantly, I don't need to patch.  Hope this can help someone. Recieved the advice from SAP. I hope they will document this.

As discussed, we have a workaround for this issue to uncomment  "#

qaaws.closedocument=true " value in the dsws.properties file. however,

this workaround can only be applied 4.0 SP05 onwards.

You can find same details in the below SAP Article (attached to the

incident for your referance):

1978536 - " # qaaws.closedocument=true " is uncommented by default

which results in holding up the session on the Webiprocessing server

You can also try the below steps and test the issue:

- Open Dashboard in the Dashboards Designer.

- Go to: Data Manager -> Connection -> Open the query -> Input Values.

- Scroll down to "closeDocument" option and map it to a spreadsheet

cell.

- Enter "TRUE" value in that cell.

- Follow this for each BIWS connection in the dashboard.

- Test the issue.

If this fails, I would suggest you to upgrade your environment to

apply the fix.

alexdc12
Participant
0 Kudos

thanks for this! Saved  my life

Former Member
0 Kudos

I'm glad to hear that it worked for you as well. 

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi Abdessamad,

Could you tell me the exact version of BO along  with patch if applied ?

There is a known issue where connections do not get released from the server.

Thanks,

Tejas

Former Member
0 Kudos

Hi Tejas,

I am using BO 4.0 SP04, and I didn't apply any patch on it!

Thank you for your help