cancel
Showing results for 
Search instead for 
Did you mean: 

Error for a specific field in a view

0 Kudos

Hello Experts,

I have am getting an error when I am trying to view data from a view that was created on top of a Oracle 11g database table. The IS version I am using is 4.1. (14.1.1.220)

_________________________________

Data Services execution failed for /opt/eim/app/dataservices/bin/al_engine. Error :

(14.1) 01-21-15 10:29:19 (E) (16554:2354147680) RES-020108: |SESSION JOB_VView_2923_61bdd06b_52f1_4289_95f7_44f4b5670d88|DATAFLOW GUID::'0000000017462852012111510291854021600000010982166400000' EMBEDDED_DATAFLOW EDF_VIEW2923 OUTPUT(EDF_VIEW2923)|STATEMENT <GUID::'0000000017462852012111510291854021600000010982166400000::0000000017462852012111510233008698400000017016754870001' QUERY "__ICC_PROFILE_VIEW__"> Column <QMNUM> was not found in table <IS_VIEW_RDR_2923_1>. Check the spelling of the referenced table and column and ensure that the table exists and such a column exists in the table. (COR-10690)

___________________________________________________________

I have confirmed that the Data Services job that load the data into the DB target table works with no issues. I am also able to view the DB table data, with that fields in it, with no issues.

As part of my solution I have tried to delete and re-create that view, however that brought up the same error message. I noticed that when I remove the field and then view the data from the view I can see the data, but when I add it back I get the same error message above.

Thank you in advance for your help.

View Entire Topic
0 Kudos

Thank you for your reply Srinivasan Vinayagam. However the issue was not security. I had them check it and there was not a reason for this.

For those that have the same issue the way I solved it is that I deleted this table from the database and re-created it with a slightly changed name. Then I re-binded the same view and rules to the "new" table. This resolved my issue.