cancel
Showing results for 
Search instead for 
Did you mean: 

Error: Could not connect to the endpoint URL while deploying Tutorial Model

md_tcon07
Discoverer
0 Kudos

Hello Experts,

I am new to AI Core and followed the Tutorial Series to get to know the environment. (Make Predictions for House Prices with SAP AI Core | SAP Tutorials)


Unfortunately I've encountered an error I am unable to resolve. In the last steps of the Tutorial, while trying to deploy the model on a server, the error "Could not connect to the endpoint URL" appears.

I would be very grateful for your assistance.

md_tcon07
Discoverer
0 Kudos

For further information: I meticulously followed every step of the Tutorial Series, i didn't change the code from the tutorial except the placeholders that were required to be replaced and the generated model is stored in my S3 Bucket. The Connection to the Bucket is stored in the Launchpad as is the connection to the GitHub. For further information feel free to ask!

gianfranco-salomone
Discoverer

Tutorial says

endpoint = "s3-eu-central-1.amazonaws.com", # Change this

 

It should be:

endpoint = "s3.eu-central-1.amazonaws.com", # `s3-` changed to `s3.`

 

Source: https://docs.aws.amazon.com/general/latest/gr/s3.html

 

RjainCap
Explorer
0 Kudos

@Gianfranco-salomone : Thank you. Your solution works, I was able to proceed. 
@MichOnSAP : If you are still struggling, I suggest take a look at this solution.

View Entire Topic
MichOnSAP
Explorer
0 Kudos

Good morning md_tcon07,

Here below is my set up and no I did not have to adjust any AWS roles.
It just comes up when it wants to publish the model back. As when it gets stuck
it will continue to publish and use the data . (xyz is just my method to mask the real key)
Thanks,
Mich

Name - default
Type - S3
Path Prefix: example-dataset/house-price-toy/model
Bucket: hello-aicore-data
Endpoint: s3-us-east-1.amazonaws.com
Region : us-east-1

verify SSL : off
Use HTTPS : on
Secret:
{
"AWS_ACCESS_KEY_ID": "xyz5",
"AWS_SECRET_ACCESS_KEY": "xyzncdl"
}

 

Name - mys3
Type - S3
Path Prefix: example-dataset/house-price-toy
Bucket: hello-aicore-data
Endpoint: s3-us-east-1.amazonaws.com
Region : us-east-1

verify SSL : off
Use HTTPS : on
Secret:
{
"AWS_ACCESS_KEY_ID": "xyzU5",
"AWS_SECRET_ACCESS_KEY": "xyzcdl"
}


From a local comand prompt listing ( same key to access)
aws s3 ls s3://hello-aicore-data/example-dataset/house-price-toy/
PRE data/
PRE model/

RjainCap
Explorer
0 Kudos
@MichOnSAP : Are you able to deploy the server? I have same configuration but the error persists. The model gets created and gets stored in the bucket, but error occurs only during the server deployment.