cancel
Showing results for 
Search instead for 
Did you mean: 

Error: Could not connect to the endpoint URL while deploying Tutorial Model

md_tcon07
Discoverer
0 Kudos

Hello Experts,

I am new to AI Core and followed the Tutorial Series to get to know the environment. (Make Predictions for House Prices with SAP AI Core | SAP Tutorials)


Unfortunately I've encountered an error I am unable to resolve. In the last steps of the Tutorial, while trying to deploy the model on a server, the error "Could not connect to the endpoint URL" appears.

I would be very grateful for your assistance.

md_tcon07
Discoverer
0 Kudos

For further information: I meticulously followed every step of the Tutorial Series, i didn't change the code from the tutorial except the placeholders that were required to be replaced and the generated model is stored in my S3 Bucket. The Connection to the Bucket is stored in the Launchpad as is the connection to the GitHub. For further information feel free to ask!

gianfranco-salomone
Discoverer

Tutorial says

endpoint = "s3-eu-central-1.amazonaws.com", # Change this

 

It should be:

endpoint = "s3.eu-central-1.amazonaws.com", # `s3-` changed to `s3.`

 

Source: https://docs.aws.amazon.com/general/latest/gr/s3.html

 

RjainCap
Explorer
0 Kudos

@Gianfranco-salomone : Thank you. Your solution works, I was able to proceed. 
@MichOnSAP : If you are still struggling, I suggest take a look at this solution.

View Entire Topic
anurag_batra
Advisor
Advisor

Hi Duschl,

The botocore.exceptions.EndpointConnectionError error occurs when there is a problem with the connection to the AWS service endpoint. This can be due to a variety of reasons incorrect configuration, or the service not being available in the specified region.

Can you validate if your stored S3 object store Creds are the same as your current S3 creds?

md_tcon07
Discoverer
0 Kudos

Hello Anurag,
we were able to fix this problem. While the S3 credentials worked for storing the ai model, for some reason we had to change them for using them to deply a model.

Thank you for answering and offering your help! 🙂

MichOnSAP
Explorer
0 Kudos
Hello. I am in the same place but months later. I have 2 Object Store secrets. Name are: default example-dataset/house-price-toy/model mys3 example-dataset/house-price-toy Url in error seems to be correct URL: "https://s3-us-east-1.amazonaws.com/hello-aicore-data?prefix=example-dataset%2Fhouse-price-toy%2Fmode..." I redid them and both appears to work for other steps. Thanks, Mich
RjainCap
Explorer
0 Kudos
@md_tcon07: can you please share what changes you did for the S3 credentials? was there any access issue for your account in S3? If so, what additional roles are needed?