cancel
Showing results for 
Search instead for 
Did you mean: 

Error connecting SAPinst GUI on AIX 5.3L from Windows XP PC for NW2004s SR2

Former Member
0 Kudos

Hello,

We are trying to install the NW2004s on AIX 5.3/DB2 8.2

We have started the SAPinst GUI on the server and trying to connect to it from our WindowsXP PC.

We are not able to connect to the SAPinst remotely.

We are getting ready to install NW2004s on AIX and DB2 UDB V8.

We start the sapinst as follow on the remote unix server:

cd /software/NW2004S/NWSR2_Installation_Master/IM_AIX_PPC64root@

[gnwux02]:

(/software/NW2004S/NWSR2_Installation_Master/IM_AIX_PPC64)> ./sapinst

[==============================] - extracting... done!

The GUI could not be started because the environment variable DISPLAY

is not set. Please make sure that this variable is defined correctly

or start the GUI on another host (for details please consult the

installation guide)

Starting GuiServer using:

/usr/lib/java -

cp /tmp/install/sapinst_exe.675980.1177373484/JAR/instgui.jar:/tmp/install/sapinst_exe.675980.1177373484/JAR/inqmyxml.jar -

Djava.security.egd=file:/dev/urandom SDTServer config=jar:sdtserver.xml

guiport=21212 sapinsthost=localhost sapinstport=21200

load resource

pool /software/NW2004S/NWSR2_Installation_Master/IM_AIX_PPC64/resourcepool.xml

guiengine: no GUI connected; waiting for a connection on host gnwux02,

port 21200 to continue with the installation

At this point we kick off the SAPinst GUI that was downloaded with the

NetWeaver 2004s on the laptop. The IP address of the Unix server is

entered, an the default port of 21212 is used. Once we click on

the "Log on" button, after about 10 seconds we get the following

message displayed on the GUI:

Could not connect to host 52.99.88.147 on port 21212

java.net ConnectException: Connection refused: connect

No further messages are displayed on the Unix side.

If we change the port on the laptop from 21212 to 21200, the following

message can be seen on the Unix side:

guiengine: login in process...............................

guiengine: login timeout; the client was unable to establish a valid

connection

We also changed the default ports and used 3600 and 3601 for testing

and exact same issue.

We also tried the following to narrow down the problem:

We kicked off SAPinst for Solution Manager 3.2 using the 6.2 SAPinst

GUI for laptop and that was successfull, meaning that SAPinst screen

came up. This indicates that we do not have issues with the ports being

blocked.

This is the output of java -fullversion:

java full version "J2RE 1.4.2 IBM AIX 5L for PowerPC (64 bit JVM) build

caix64142ifx-20061222 (ifix 113727: SR7 + 112603)"

./sapinst -v

[==============================] - extracting... done!

This is SAPinst, version 701, make variant 700_REL, build 860072

compiled on Oct 5 2006, 23:40:13

Also, the user root that is kicking off SAPinst has unlimited for the mentioned values:

ulimit -a

time(seconds) unlimited

file(blocks) unlimited

data(kbytes) unlimited

stack(kbytes) unlimited

memory(kbytes) 32768

coredump(blocks) unlimited

nofiles(descriptors) unlimited

<b>

When we run a 6.4 install in a similar fashion on this box, the connectivity is not an issue and it works on the same ports 21200 and 21212</b>

If anybody has faced this situation please suggest a solution.

Thanks,

Dnyandev

Accepted Solutions (0)

Answers (4)

Answers (4)

Former Member
0 Kudos

Hi

if you restarted sapinst multiple times you probably should check for orphaned sapinst and sapinst-related (java) processes .

Just look for sapinst and sapinst-related java processes and terminate them , if you don't have an sapinst running on that box .

Furthermore you should check , whether sapinst starts it's listening .

Perform the following procedure

1. start sapinst

2. issue

netstat -an|grep 21212

Check , that there is something listening on Port 21212 (Unless you did'nt choose another Port of course) if sapinst is started and nothing is listening if there is no sapinst active.

On some OS there is an delay , where you can't restart sapinst immediately . There you have to wait until the ports are freed .(usually 1-2 minutes,check via

netstat

as decribed above)

Hth + best regards

dirk

andreas_herzog
Active Contributor
0 Kudos

- set TMP directory (where you would like to have the installation log files)

- set SAPINST_JRE_HOME to point to your java directory

- set LIBPATH

and then invoke sapinst by starting:

> <b>sapinst SAPINST_START_GUI=false</b> on the aix box

sapinst will extract and wait for sapinstgui to connect...if you'd like to start the gui on your local pc, either start STARTINSTGUI using double click or use a command prompt shell:

> <b>startinstgui -host <your server ip address> -port <21212></b> [21212 is the default port...]

startinstgui will be found on the windows installation master NW2004s...

GreetZ, AH

Former Member
0 Kudos

Hi

and furthermore

memory(kbytes) 32768

could also probably cause problems

Best regards

dirk

Former Member
0 Kudos

Hi

try starting sapinst on AIX with <b>-nogui</b> Option

See installation Guide

>>>snip<<<

3. Enter the following commands:

cd <Installation_Master_DVD>/IM_<OS>

./sapinst -nogui

For more information, see Running SAPinst on UNIX [page 86].

>>>unsnip<<<

Check , whether you are having the proper SAPINST GUI on Windows .

Use that one from the Installation Master , you are using .

Check proper JDK's/JRE's on AIX and Windows , see Installation Guide .

Hth + best regards

dirk