cancel
Showing results for 
Search instead for 
Did you mean: 

Error cannot find module ...

lucie16
Active Participant
0 Kudos
686

Hi all,

I have a project in IRPA Cloud Studio and everytime I run it, it shows me error:

It says:

"could not load project file in C:\\Users\\s1756\\AppData\\Local\\SAP\\Intelligent RPA\\Projects\\5dad4b1e-b29f-4862-aa3b-bd17e09fe637\\dist"

"Error: Cannot find module 'C:\\Users\\s1756\\AppData\\Local\\SAP\\Intelligent RPA\\Projects\\5dad4b1e-b29f-4862-aa3b-bd17e09fe637\\dist\\package.json'\nRequire stack:\n- C:\\Users\\s1756\\AppData\\Local\\SAP\\Intelligent RPA\\Projects\\8dc33ffc-9190-4e70-8e52-f445ffda5337\\dist\\bundle.js\n- C:\\Users\\s1756\\AppData\\Local\\SAP\\Intelligent RPA\\Projects\\8dc33ffc-9190-4e70-8e52-f445ffda5337\\index.js\n- C:\\Users\\s1756\\AppData\\Local\\SAP\\Intelligent RPA\\Projects\\8ce7eae6-6927-442f-be4a-4eeefc0707fa\\index.js"

Sometimes the workflow continues and ignore it. But I think it can cause problems.

Does anybody know, how can I solve it?

Btw. I have Desktop Agent version 2.0.24 and dependencies 1.25.57.

Lucie

Accepted Solutions (0)

Answers (2)

Answers (2)

lucie16
Active Participant
0 Kudos

Thank you vishalrathi21 for your answer.
I did ad 1 - I deleted and added dependencies again and seems to be working now.

I oppened the folder and there is nothing except bundle.js

Could it couse other problems in future?

I also generated package and tried to create a trigger, but it shows me error:

Now I can't run it via Desktop Agent. Although the trigger seems to be created. But there could be another problem?

These are my depedecies. Btw. I had Excel dependency in my project, but I deleted it.

Regards

Lucie

vishal
Contributor
0 Kudos

Hi Lucie,

At high level - If i browse same directories in my system can see the files "package.json / bundle.js / index.js" seem to be runtime files/config files of Projects.

The error calls out "could not load project file" & "could not find module" - we are not sure if the missing file/module belongs to specific project or your IRPA setup (SDKs or Agent or Studio installation)

  1. The first troubleshooting step would be to focus on project dependencies setup (try only if issue with specific project, else if all projects showing error then jump to point #2) --- within the project update dependencies to latest version if available / delete the SDK dependencies from project and add them again. Suggesting to start with CORE SDK as error is specifically showing CORE SDK related messages.
  2. If above does not work, can try reinstalling the setup (desktop agent, desktop studio etc.). Of course before that need to backup you existing project(s) using export option and later import / reuse / restore again in new setup.
  3. If issue persists for specific project, then need to check the artifacts of the project and maybe also recreate it if needed (as last resort)

Hope it helps, give it a try if not yet done and let us know..

Regards,

Vishal Rathi