cancel
Showing results for 
Search instead for 
Did you mean: 

Error at creating Client Proxy of external webservice (WSDL)

Former Member
0 Kudos
307

Hi Experts,

I try to create a Client Proxy Object out of an external webservice. Here is the WSDL URL:

[http://www.webservicex.net/CurrencyConvertor.asmx?wsdl]

I try to create it with this URL and then I get the error message

Not implemented

Exception of class CX_SIDL_INTERNAL_ERROR

I found two other threads with a similar problem:

But there is no solution that worked for me. In the first thread it is mentioned, that the code between

<wsdl:binding name="XXXXHttpGet" type="tns:XXXHttpGet">

and it's closing brackets should be removed in a local file. I tried that and was able to create a client proxy object out of this local wsdl-file. But then I called the webservice with the folling coding for testing:


report  z_currency_converter.

data: convert type ref to zzzco_currency_convertor_soap.
try.
    create object convert
  exporting
    logical_port_name  = 'Z_LP'
        .
  catch cx_ai_system_fault .
endtry.
   data: output type zzzconversion_rate_soap_out  .
   data: input type zzzconversion_rate_soap_in .

   input-from_currency = 'EUR'.
   input-to_currency = 'USD'.
try.
call method convert->conversion_rate
  exporting
    input  = input
  importing
    output = output
    .
 catch cx_ai_system_fault .
 catch cx_ai_application_fault .
endtry.

write output-conversion_rate_result.

The same code worked fine in another system. In this "older" system could also create a client proxy, I think because it has a newer Support Pack version.

SAP says the following:

The problem is that this WSDL uses two bindings different from SOAP

binding which is not in conformance with Basic Profile 1.1 -

http://www.ws-i.org/Profiles/BasicProfile-1.1.html#WSDLBINDINGS .

I looked in the document, but I do not know where the problem in the WSDL file exactly is. What have I to change? Or can somebody give me the URL of a free webservice, that you used for creating a client proxy with a new support pack standing? In the "old" system there is not yet the SOAMANAGER but in the one where it doesn't work.

I hope you have an idea.

Thanks a lot in advance!

Best Regards,

Ingmar

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

I think it is the problem of version.U need to ask SAP to release some patch levels to correct it.

Regards

Snehasish