cancel
Showing results for 
Search instead for 
Did you mean: 

ERROR - A system error has occured in lock management

Former Member
0 Kudos

Dear All ,

I have a major issue in my workflow in production client . In SWEL there are some workflows which

got started & then error occured as per the message " A system error has occured in lock management " and no workitem gets created .

This issue happened just 1 day back and still continues somtimes .

If any one have any idea on the issue , what is the root cause of the issue , please suggest how to solve the same .

Regards

Prabhu

Accepted Solutions (0)

Answers (1)

Answers (1)

surjith_kumar
Active Contributor
0 Kudos

Hi,

Check WF-BATCH user id is locked or not. Get the help of basis team for this.

Regards,

Surjith

Former Member
0 Kudos

No WF-BATCH is not locked . This issue does not happen every time , it happens some times .other wise workflow runs fine .

I will tell you when i checked abot the error message by clicking F1 help i got the below message details-

An error occurred in lock management when attempting to set a lock on table SWWWIHEAD.

The data cannot be processed at the moment. The data is displayed.

So i think there is some issue happens in updating the entry in the table which happens some times , and gets rectified automatically . But the workflow which gets affected by this error does not start .

so any idea on the same .

Regards

Prabhu

former_member185167
Active Contributor
0 Kudos

Hello,

Check if all is well in SWU3.

How is this workflow started? Check SWIA to see if another workflow is being started at exactly the same time.

regards

Rick Bakker

Hanabi Technology

Former Member
0 Kudos

Check SM58 transaction Code.

Thanks

Arghadip

Former Member
0 Kudos

Did you find a solution? I have a similar problem.