cancel
Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

EHP6 UPGRADE ISSUE

Former Member
0 Kudos

Dear Team,

We are facing issue during EHP6 upgrade , Every time Our SUM is

stoppingand once we are continuing it is moving and again its stopping

after

some

time , I am attaching the log , Please help me ,


Log file is as below.

+++++++++++++++++++++++++++++++++++++++++++++++++

*** ERROR in DB6Connect[dbdb6.c, 1835] CON = 0 (BEGIN)                              6  21.327136

4 ETW000 TRACE-INFO: 48:  [     dev trc,00000]  &+     DbSlConnectDB6( SQLConnect 😞 [IBM][CLI Driver] SQL30081N  A communication error has been detected. Communication

4 ETW000 TRACE-INFO: 49:                                                                                                           16  21.327152

4 ETW000 TRACE-INFO: 50:  [     dev trc,00000]  &+     protocol being used: "TCP/IP".  Communication API being used: "SOCKETS".  Location where the error was detected: "

4 ETW000 TRACE-INFO: 51:                                                                                                           14  21.327166

4 ETW000 TRACE-INFO: 52:  [     dev trc,00000]  &+     192.168.1.51".  Communication function detecting the error: "connect".  Protocol specific error code(s): "10060",

++++++++++++++++++++++++++++++++++++++

Regards

RK

+91-8285932768

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Dear all,

Issue got resolved after upgrading the network driver , Suggested by Microsoft and SAP both.

Thanks all for your help.

Regards

RK

Answers (5)

Answers (5)

former_member182657
Active Contributor
0 Kudos

Earlier suggested Network issue for same.

Regards,

former_member213250
Active Participant
0 Kudos

Hi RK
What is the current status of the issue.. any recommendations helped ?
After changing Host names and PORT names ?

Regards
Venkat

former_member182657
Active Contributor
0 Kudos

Hi,

192.168.1.51".  Communication function detecting the error: "connect".  Protocol specific error code(s): "10060",

This shows the issue could be related with your network end.Could you check with SAP Note 413330 - Network timeouts

Regards,

Gaurav

Former Member
0 Kudos

Dear All,

We are not able to proceed become show stopper.

RK

former_member188883
Active Contributor
0 Kudos

Hi Rableen,

Restart the database and check again. Also check whether you have set the parameter SVCE_NAME in db configuration as well as db2 port is defined in /etc/services.

Regards,

Deepak Kori

Former Member
0 Kudos

Hi Deepak,

Thanks for your reply , Hope you will resolve my issue ....

SVCENAME     sapdb2PRD

and db2 port is defined in /etc/services

sapdb2PRD5912/tcp# SAP DB2 Communication Port

This is our Production server , it is tough to take restart this time DB server ...Everything is working fine even good performance of sap we are having then why getting error.

Our golive date is spoiled due to this.

Regards

RK

former_member188883
Active Contributor
0 Kudos

Hi RK,

As I understand correctly, you already have database and application running on the same server on which upgrade is being performed and existing application is running very fine without nay issues.

Correct me on my understanding please.

I would suggest you to check the following configurations

1) DB2 registry entry for db2comm = tcpip. Use command db2set -all to check

2)  Check whether db is listening to the communication port using command

   netstat -an | find "5912"

3) disable any firewall running on the server.

Regards,

Deepak Kori

Former Member
0 Kudos

Hi Deepak,

Our DB server is at separate host 192.168.1.51 and CI is at separate 192.168.1.7 ,

C:\Windows\system32>db2set -all

[e] DB2DBDFT=PRD

[e] DB2PATH=F:\db2\db2prd\db2_software\

[i] DB2_SKIP_VIEWRECREATE_SAP=TRUE [DB2_WORKLOAD]

[i] DB2_RESTORE_GRANT_ADMIN_AUTHORITIES=YES [DB2_WORKLOAD]

[i] DB2_BLOCKING_WITHHOLD_LOBLOCATOR=NO [DB2_WORKLOAD]

[i] DB2_AGENT_CACHING_FMP=OFF [DB2_WORKLOAD]

[i] DB2_TRUST_MDC_BLOCK_FULL_HINT=YES [DB2_WORKLOAD]

[i] DB2_CREATE_INDEX_COLLECT_STATS=YES [DB2_WORKLOAD]

[i] DB2_ATS_ENABLE=YES [DB2_WORKLOAD]

[i] DB2_RESTRICT_DDF=YES [DB2_WORKLOAD]

[i] DB2_DUMP_SECTION_ENV=YES [DB2_WORKLOAD]

[i] DB2_LIMIT_FENCED_GROUP=NO [DB2_WORKLOAD]

[i] DB2_CREATE_DB_ON_PATH=YES [DB2_WORKLOAD]

[i] DB2_OPT_MAX_TEMP_SIZE=10240 [DB2_WORKLOAD]

[i] DB2_WORKLOAD=SAP

[i] DB2_TRUNCATE_REUSESTORAGE=IMPORT [DB2_WORKLOAD]

[i] DB2_MDC_ROLLOUT=DEFER [DB2_WORKLOAD]

[i] DB2_ATM_CMD_LINE_ARGS=-include-manual-tables [DB2_WORKLOAD]

[i] DB2_SKIPINSERTED=YES [DB2_WORKLOAD]

[i] DB2_VIEW_REOPT_VALUES=YES [DB2_WORKLOAD]

[i] DB2_OBJECT_TABLE_ENTRIES=65532 [DB2_WORKLOAD]

[i] DB2_OPTPROFILE=YES [DB2_WORKLOAD]

[i] DB2_IMPLICIT_UNICODE=YES [DB2_WORKLOAD]

[i] DB2_RUNTIME_DEBUG_FLAGS=TOLERANT_FLOAT [DB2_WORKLOAD]

[i] DB2STMM=APPLY_HEURISTICS:YES [DB2_WORKLOAD]

[i] DB2_INLIST_TO_NLJN=YES [DB2_WORKLOAD]

[i] DB2_MINIMIZE_LISTPREFETCH=YES [DB2_WORKLOAD]

[i] DB2_REDUCED_OPTIMIZATION=4,INDEX,JOIN,NO_TQ_FACT,NO_HSJN_BUILD_FACT,STARJN_CARD_SKEW,NO_SORT_MGJOIN,CART O

_WORKLOAD]

[i] DB2NOTIFYVERBOSE=YES [DB2_WORKLOAD]

[i] DB2_INTERESTING_KEYS=YES [DB2_WORKLOAD]

[i] DB2_EVALUNCOMMITTED=YES [DB2_WORKLOAD]

[i] DB2_EXTENDED_OPTIMIZATION=NLJOIN_KEYCARD,IXOR [DB2_WORKLOAD]

[i] DB2_ANTIJOIN=EXTEND [DB2_WORKLOAD]

[i] DB2COMPOPT=327685,131776 [DB2_WORKLOAD]

[i] DB2ATLD_PORTS=60000:65000

[i] DB2INSTOWNER=PRDDB

[i] DB2PORTRANGE=5914:5917

[i] DB2ENVLIST=INSTHOME SAPSYSTEMNAME dbs_db6_schema DIR_LIBRARY

[i] DB2_GRP_LOOKUP=,TOKEN [DB2_WORKLOAD]

[i] DB2INSTPROF=F:\DB2\DB2PRD

[i] DB2COUNTRY=1

[i] DB2COMM=TCPIP [DB2_WORKLOAD]

[g] DB2_EXTSECURITY=YES

[g] DB2PATH=F:\db2\db2prd\db2_software\

[g] DB2INSTDEF=DB2PRD

Yes it is listening and establishing port 5912.

As 2000 User is connected to PRD working now.

Regards

RK

former_member188883
Active Contributor
0 Kudos

Hi RK,

As you have distributed environment you may need to check the following

1) Look out for TCPIP DB2 registry entries as well as OS entries as described in link below

http://www-01.ibm.com/support/docview.wss?uid=swg21231084

2)  Ensure that Firewall is off across all SAP server.

Regards,

Deepak Kori

Former Member
0 Kudos

Hi Deepak,

We have done the registry entry and there is no firewall running on this , then also we are still facing the issue.

Regards

RK

S_Sriram
Active Contributor
0 Kudos

Hi

1. Are you getting any error message in SM21 log?

2. Could you check  this SAP KBA

2072947 - First steps for troubleshooting SQL30081N Communication errors


BR

SS

srinivasan_vinayagam
Active Contributor
0 Kudos

Hi Rableen,

You may get the solution from this thread.

Regards,

V Srinivasan