cancel
Showing results for 
Search instead for 
Did you mean: 

EHP4 stack6 upgrade stucks at ACT_UPG

Former Member
0 Kudos
66

Hello,

We're upgrading our system ECC6 into EHP4 stack6 and we get stuck at the phase ACT_UPG. We remark the the job RDDMASGL fills up the memoire until the extended memory is exhausted. The system generated a dump TSV_LIN_ALLOC_FAILED and the upgrade stopped with an error.

Did someone have the same error with the upgrade?

Our system is on Windows server 2005 Standard 64X, and MSSQL server 2005

Many thanks for your answer

Best regards,

Hoangson

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Dear Dang,

This is a general performance error and will come if resource are completely utilized.

Try to rerun the same step again and check where the resources are gettying utilized.

You can analysis using ST22.

Hope it wil lhelp!

Former Member
0 Kudos

Dear Gargan,

In ST22, The storage location is "session memory". The job allocates 2GB of Extended Memory and get killed by the system with a dump TSV_LIN_ALLOC_FAILED. I tried repeating the phase many time but the same error. We're trying to allocate more memory for the job and hop that will work.

Answers (2)

Answers (2)

Former Member
0 Kudos

Follow up the thread

/thread/1427701 [original link is broken]

Solution is increase the value PHYS_MEMSIZE of the shadow instance

Former Member
0 Kudos

Hi Hangson,

Follow the note 353579, which is exactly suitable solution for your dump related issue.

Also I suggest keep more vitual memory (apprx 28GB) till the end of upgrade.

We followed same before on the same issue during EHP4 upgrade.

RG//

Ramesh.

Former Member
0 Kudos

Hi Ramesh,

I take on the note 353579, and we have the parameter ztta/max_memreq_MB=2047 as recommanded by the note.

We have also the swap = 45GB, but we still have the problem. Did you make some other changes to get out of the problem?

Thanks,

Hoangson

Former Member
0 Kudos

Hi,

Actually we I set ztta/max_memreq_MB more than double i.e. 5000, we also did OS level restart to freeze the heap memory.

Try to the same and let us know.

Regards,

Ramesh.

Former Member
0 Kudos

Hi all,

I found a thread in the forum whichs sais to increase the value of PHYS_MEMSIZE, and it solved my problem.

/thread/1427701 [original link is broken]

The default value of this parameter on the shadow instance is 24% which allow only 40MB for the heap memory. We increase this parameter to 6GB and the job has enough memory to finish.

Many thanks for your helpfull answers

Former Member
0 Kudos

hi HoangSon,

may i know what parameter you are changing to solve the issue at ACT_UPG? thanks.

Former Member
0 Kudos

Hi Hariyono,

I changed the parameter PHYS_MEMSIZE to a specific value (6000) to bypass the problem. It was due to the fact that the job need more memory than default (>2GB) to finish.

Hope that helps you.

Best regards,

HoangSon Dang