cancel
Showing results for 
Search instead for 
Did you mean: 

eFashion and Island Reorts - Cannot load in crystal enterprise under normal user

Former Member
0 Kudos

Hi,

I am having a strange issue with efashion and Island Resorts. I have converted them from unv to unx. The following are working

Issue:

1. Cannot run under any other user with Crystal enterprise. (only works with admin)

2. Cannot run under Web intelligence Rich client. (only works with admin)

Tried:

1. Recreating universe from orginals

2. Changing security access to connections.

3. Re-creating ODBC on server.

4. Tried on Win7 x64 bit machine (Tried also Adding ODBC  to shared access file on server)

5. Tried on Win XP 32 bit machine (Tried also Adding ODBC  to shared access file on server)

 

Running:

  1. BOBJ SP4 Patch 3 Server/Client/Crystal Enterprise (Windows 2008 datacenter)
  2. Windows 7 x64 bit for local machine

Outcomes:

1. Can run sucesfully in Web Intelligence Web Admin account and Power user

2. Can run via Crystal Enterprise and Webi Rich Client when logged in as admin

3. Cannot run via Crystal Enterprise or Webi Rich Client when logged in as Power or any other user.(able to view the query, move objects into panel but when i press refresh the error below occurs)

The error i am getting from webi on the client machine is .... I believe if i resolve this issue it will resolve the my crystal issue to

Database error: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified. (IES 10901) (WIS 10901)

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

After a long week i have managed to resolve the issue.

1. Log into CMC

2. Go to Manage > Top-Level Security > All Servers

3. Highlight everyone, Clicked Assign Security

4. Click the advanced tab then Add/remove rights

5. Under "General"  scroll to the buttom and ensure "View Objects" is selected

6. Apply and close everything.

This is just the basic solution, you can add a user group rather than giving everyone "view objects" to increase security.

Not to sure why this was happening, but this change also fixed for me

1. 1734478 - Failed to find an available RAS (with CR 2011 saving to Enterprise Portal)

Answers (0)